Jump to content
Ryan Parry

AFV - Constant Voice Disconnects on vPilot

Recommended Posts

For the past two days I've been having an issue where I am disconnected from AFV constantly during a flight. It happens on an ATC frequency and on unicom. It's happening every few minutes and extremely annoying, not to mention difficult to talk to ATC when I lose connection like this. I'd post this in vPilot, but this seems like an AFV issue (maybe not?). I'm not losing connection to Vatsim or anything else, it's just the voice server that loses connection and reestablishes connection a few seconds later.

Any ideas?

image.png.f7239ceafc27aead4d9178cae54c956e.png


Ryan Parry - 965346

vZOA Air Traffic Manager

www.pilotcentral.org | www.oakartcc.org

Share this post


Link to post
Share on other sites

I didn't have any trouble like this until I upgraded my computer hardware. I hope I haven't paid thousands for troublesome equipment...

 

Don Whyte

Vatsim 925580

Windows 10 Home
Asus TUF Gaming x570 Plus Wifi motherboard
AMD Ryzen 7 3800X processor
32 G Memory
Corsair M600 1TB M2 drive

Share this post


Link to post
Share on other sites
3 hours ago, Don Whyte said:

I didn't have any trouble like this until I upgraded my computer hardware. I hope I haven't paid thousands for troublesome equipment...

 

Don Whyte

Vatsim 925580

Windows 10 Home
Asus TUF Gaming x570 Plus Wifi motherboard
AMD Ryzen 7 3800X processor
32 G Memory
Corsair M600 1TB M2 drive

Out of curiosity, what build of Windows 10 are you on? Did you update all the way to the new 2004 version? I only ask because you're saying this is happening on a new system, and it has occurred to me this started happening after I pushed through the new 2004 update. If you're on W10 Home v2004, I wonder if there is something going on with that version that the AFV Team can chase down.


Ryan Parry - 965346

vZOA Air Traffic Manager

www.pilotcentral.org | www.oakartcc.org

Share this post


Link to post
Share on other sites

That would be good if that could be investigated. I see quite a number of complaints about this disconnect issue.

 

Share this post


Link to post
Share on other sites

Moderator Notice:
Moved to AFV Windows Support


Brant Marshall
General Manager - VATSIM Social Media
VATSIM Web Developer
[email protected]

9KMxVhG.png

Please post feedback, questions, or concerns about the forum here.

Share this post


Link to post
Share on other sites

If anyone else has this same issue, please make yourself known below, stating your Windows build version.


NÉSTOR PÉREZ
WEB & SERVER DEV TEAM
##  [email protected]
Facebook   Twitter   Instagram
VATSIM Logo

Share this post


Link to post
Share on other sites

I'm trying to analyze packets on my network to see if there are any issues, I was able to identify AFV traffic using UDP port 50000 but there is too much TCP traffic to make a clear determination as to what is Vatsim/AFV. Am I correct to assume AFV is only using UDP? I had no issues with the traffic I could see while experiencing disconnects.


Ryan Parry - 965346

vZOA Air Traffic Manager

www.pilotcentral.org | www.oakartcc.org

Share this post


Link to post
Share on other sites
Posted (edited)

The traffic to focus on would be the UDP traffic.

You'll see UDP heartbeating every 3 seconds, with the client sending a heartbeat request, and the server replying with a heartbeat response. If 3 responses are not received (for whatever reason), the client will disconnect. 

I suggest that if you're able to capture your traffic over a vpilot disconnect event, you have a look at what is happening with the heartbeating.

Edited by Mark Barnes

Share this post


Link to post
Share on other sites

I'm having this issue with xPilot. In addition I'm having an EndReceive Failed message and a disconnect from the network (reported before). This happens on unicom in an area with no ATC or other pilots. My windows build is 19041.388 (same as Don). Latest xPilot and Xplane 11.41.

[13:20:48] xPilot Version 1.3.26
[13:20:48] Performing version check...
[13:20:48] Version check complete. You are running the latest version.
[13:20:48] Server list successfully downloaded. 8 servers found.
[13:20:48] X-Plane connection established.
[13:21:30] Connecting to network...
[13:21:30] Connected to network
[13:21:31] [SERVER] Welcome back to VATSIM! Our new voice technology is now live - if you have any questions or need support visit vats.im/audio for required downloads, instructions and tutorial videos. If you need further support visit the Audio for VATSIM forums at vats.im/afv
[13:21:31] Connected to voice server.
[13:23:10] EndReceive failed: (10060) A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
[13:23:10] Disconnected from the network.
[13:23:19] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[13:23:21] Connected to voice server.
[13:24:54] Waiting for X-Plane connection...
[13:25:07] X-Plane connection established.
[13:25:29] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[13:25:30] Connected to voice server.
[13:30:44] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[13:30:45] Connected to voice server.
[13:32:56] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[13:32:57] Connected to voice server.
[13:39:57] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[13:39:59] Connected to voice server.
[13:43:07] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[13:43:08] Connected to voice server.
[15:53:00] Connecting to network...
[15:53:00] Connected to network
[15:53:00] [SERVER] Welcome back to VATSIM! Our new voice technology is now live - if you have any questions or need support visit vats.im/audio for required downloads, instructions and tutorial videos. If you need further support visit the Audio for VATSIM forums at vats.im/afv
[15:54:49] EndReceive failed: (10060) A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
[15:54:49] Disconnected from the network.
[15:54:50] Disconnected from the voice server.
[15:55:12] Connecting to network...
[15:55:12] Connected to network
[15:55:12] [SERVER] Welcome back to VATSIM! Our new voice technology is now live - if you have any questions or need support visit vats.im/audio for required downloads, instructions and tutorial videos. If you need further support visit the Audio for VATSIM forums at vats.im/afv
[15:55:12] Connected to voice server.
[15:57:38] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[15:57:39] Connected to voice server.
[15:57:51] EndReceive failed: (10060) A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
[15:57:51] Disconnected from the network.
[15:57:52] Disconnected from the voice server.
[15:58:54] Connecting to network...
[15:58:54] Connected to network
[15:58:54] [SERVER] Welcome back to VATSIM! Our new voice technology is now live - if you have any questions or need support visit vats.im/audio for required downloads, instructions and tutorial videos. If you need further support visit the Audio for VATSIM forums at vats.im/afv
[15:58:55] Connected to voice server.
[15:59:25] [BROADCAST] VATEUR2: Ding Ding! There is an exam in progress on Malaga Approach (LEMG_APP). Come fly out of Malaga until 1800z to help Mike Oulton obtain his S3 rating! IFR and VFR will be appreciated.
[16:00:38] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:00:39] Connected to voice server.
[16:00:49] EndReceive failed: (10060) A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
[16:00:49] Disconnected from the network.
[16:00:49] Disconnected from the voice server.
[16:01:14] Connecting to network...
[16:01:14] Connected to network
[16:01:14] [SERVER] Welcome back to VATSIM! Our new voice technology is now live - if you have any questions or need support visit vats.im/audio for required downloads, instructions and tutorial videos. If you need further support visit the Audio for VATSIM forums at vats.im/afv
[16:01:14] Connected to voice server.
[16:03:40] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:03:41] Connected to voice server.
[16:06:40] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:06:41] Connected to voice server.
[16:10:41] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:10:42] Connected to voice server.
[16:18:54] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:18:55] Connected to voice server.
[16:23:44] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:23:45] Connected to voice server.
[16:25:04] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:25:05] Connected to voice server.
[16:29:36] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:29:37] Connected to voice server.
[16:45:38] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:45:39] Connected to voice server.
[16:48:26] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:48:27] Connected to voice server.
[16:50:41] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:50:42] Connected to voice server.
[16:52:20] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:52:21] Connected to voice server.
[16:52:34] [BROADCAST] VATEUR2: Ding ding! There is an S3 - TMA Controller CPT happening on Cairo Director (HECA_APP) until 1800z. Come help Ali earn his S3 either IFR or VFR are welcome!
[16:54:38] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:54:39] Connected to voice server.
[16:57:44] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[16:57:46] Connected to voice server.
[17:03:35] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[17:03:36] Connected to voice server.
[17:09:40] Disconnected from voice server: Lost server connection. Attempting to auto-reconnect...
[17:09:41] Connected to voice server.

 


KntU2Cw.jpg

Share this post


Link to post
Share on other sites

@Dace Nicmane The fact that not only the voice connection is failing, but that you're also getting EndReceive errors which disconnect you from the network points towards a poor internet connection either on your end or in between your end and the servers. They are completely separate systems, which means that one being "broken" doesn't mean the other one's "broken" too. The Audio connection is also more sensitive to connection issues; hence why you lose connection more times to this server than to FSD.


NÉSTOR PÉREZ
WEB & SERVER DEV TEAM
##  [email protected]
Facebook   Twitter   Instagram
VATSIM Logo

Share this post


Link to post
Share on other sites

In my case unlike Dace Nicmane I don't get the EndReceive errors, only the "Disconnected from voice server: Lost server connection. Attempting to auto-reconnect... [16:57:46] Connected to voice server" sequence.

Don Whyte

Share this post


Link to post
Share on other sites

I have been running into the same issue all afternoon today. I've had times where I got disconnected from the voice server once or twice during a flight, but for some reason this afternoon it has become much more severe, I'm getting disconnected every 1-2 minutes and I'm barely able to pick up clearance from ATC. Going to give the flying a break for tonight and try again tomorrow to see if it persists.

Running Windows 10 Version 2004 Build 19041.388

Share this post


Link to post
Share on other sites

intermittent

On 8/3/2020 at 8:20 AM, Mark Barnes said:

The traffic to focus on would be the UDP traffic.

You'll see UDP heartbeating every 3 seconds, with the client sending a heartbeat request, and the server replying with a heartbeat response. If 3 responses are not received (for whatever reason), the client will disconnect. 

I suggest that if you're able to capture your traffic over a vpilot disconnect event, you have a look at what is happening with the heartbeating.

Now that I am back from vacation I've been able to take a look. I can see the heartbeat and everything seems fine, the disconnects seem to happen when I get a flood of SSDP traffic, I presume for uPnP, or DNS query traffic in between the heartbeat. There is traffic from AFV to me, and then the SSDP/DNS traffic, and then traffic from me to AFV, but that seems like it is the vPilot reconnecting as the time since first frame resets at that point. It happens mostly with SSDP traffic, sometimes DNS, and once it happened with nothing else going on. So for some reason the connection resets when there is an SSDP broadcast. This does not happen every time I get the SSDP traffic though, I can go up to 20~ minutes with these broadcasts happening and stay connected. I have not seen it disconnect under any other circumstances.

 


Ryan Parry - 965346

vZOA Air Traffic Manager

www.pilotcentral.org | www.oakartcc.org

Share this post


Link to post
Share on other sites

I presume the SSDP and DNS traffic is on a different port to AFV? My wild guess would be to try updating your NIC driver or use a different NIC.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...