By Ross Carlson 887155
#514661 This should fix the XML error:

http://vstars.metacraft.com/Assets/File ... -1.1.4.exe

Be sure to delete the existing config file first, or choose the "empty config file" box when installing 1.1.4. That will overwrite your existing config file with a correct one.
By Mark Swan 1351762
#515047 I installed vSTARS 1.1.5 (and emptied the config file through the installer), I opened the facility file in vSTARS successfully, but when I press ctrl+s to open settings, it shows an Unhandled Exception error.

System.ArgumentOutOfRangeException: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value)
at cs.f()
at cs.g()
at cs..ctor()
at cx.a(Object A_0, KeyEventArgs A_1)
at System.Windows.Forms.Control.OnKeyDown(KeyEventArgs e)
at System.Windows.Forms.Control.ProcessKeyEventArgs(Message& m)
at System.Windows.Forms.Form.ProcessKeyPreview(Message& m)
at System.Windows.Forms.Control.ProcessKeyPreview(Message& m)
at System.Windows.Forms.Control.ProcessKeyMessage(Message& m)
at System.Windows.Forms.Control.WmKeyChar(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.UserControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
By Mark Swan 1351762
#515055 I do see a dialog message which says "Error downloading server list", which seems to appear every time I initially launch vSTARS. When I open the facility file, the only 2 messages in the chat log are "Performing version check" and "Version check complete...".
By Ross Carlson 887155
#515058 Not that I know of ... if it were my machine, I'd run a packet sniffer and see if I can figure out why the download is failing.

If you wait until after the server list download error appears BEFORE opening the settings, does it work? It should show you the last-saved server list, one of which is included in the default empty config file.
By Ross Carlson 887155
#515062 Yup, somehow your cached server list got wiped out. I've looked through the code and I don't see how that could happen.

In your config file, replace <CachedServers/> with this:
Code: Select all  <CachedServers>
    <string>4k1TtUZ1nMPNLZ+wSpkWmh+XJ59IS8vu</string>
    <string>cLr0UMkbKn0RaJtf4vbnSEezPrpv2jM3</string>
    <string>u65ZS/Db6ogfeAJf3VFD5AqplOiZL8Yc</string>
    <string>nFMkI7Z/mS2LrNEoqFqyburALllzrYN2</string>
    <string>Ij0W+XaSQ5H9VRX3u5NM40Fd3OA6KgdW</string>
    <string>UGVYQmHNW7tRUr5TOuo0LvpEILpnjd1TQV3c4DoqB1Y=</string>
    <string>VyZd/HPj+UoBGBdwLLFTaPW6xQAyf3uK</string>
    <string>yypsknI4KOTZnVFwvcELJIAhROfFU/nI</string>
    <string>Q99hP/C9u0VR2pRbNTcDxqvo6ZXMuizo</string>
    <string>gdXXJARo4KuT0P/Mwm9OebI6vX3jZLpj</string>
    <string>DUW+7vfFVZYEYjvWSgGuBQTorBTrarAr</string>
    <string>IaAPNojEBRqyxhdwujS9JkFd3OA6KgdW</string>
    <string>0iial2q8AXrEt6yVYzjP5Ef/C+UlFC1a</string>
    <string>fvwcVNu5aTmeNNIVPIPtTVQ0gSUhHKzy</string>
    <string>mQkHhEUclR+hhgpbr9/RU5ImYQ1n8cvN</string>
    <string>hCNziza/NPW576xAv5UKIZ6CLNprOcya3hmgV5zn3KE=</string>
  </CachedServers>


I would like to understand how the cached servers list got wiped out, so if this problem recurs, please let me know ... we might be able to get it fixed if we are able to reproduce it.