By Erich Berner 834484
#532316 Hi Ross

Newly installed P3D v.4.5, vPilot, fresh W10 64 installation

Have used VATSIM and VPilot for years and have recently run into this issue where my PTT assignment not longer allows me to transmit. Newly installed W10, P3D and vPilot. I can assign the button in the vPilot's settings/audio, but when I press the button in sim the Tx doesn't light and no-one can hear me.

I've checked everything else which I consider obvious. As it's a new W10 install, I will check whether I have allowed access to the microphone during the windows setup process. But apart from this, I'm not sure why this should happen.
By Kenneth Haught 1067681
#532317 One common issue that brings this up is 1) do you run P3D as an admin, and 2) is vPilot similarly set to run as an admin on launch (or is launched as an admin manually).

Also, and this may be unnecessary to ask but are you tuned to an active ATC frequency? Voice is only permitted to tx on ATC frequencies as the controller "creates" the voice room during our connection process. So no ATC, no voice as it stands currently. :)
By Erich Berner 834484
#532326
Kenneth Haught 1067681 wrote:One common issue that brings this up is 1) do you run P3D as an admin, and 2) is vPilot similarly set to run as an admin on launch (or is launched as an admin manually).

Also, and this may be unnecessary to ask but are you tuned to an active ATC frequency? Voice is only permitted to tx on ATC frequencies as the controller "creates" the voice room during our connection process. So no ATC, no voice as it stands currently. :)


Both programs run as Admin and the correct active frequencies are tuned. The MIC button on the radio stack is also 'on'
By Ross Carlson 887155
#532328 Type ".debug" into the vPilot window, and then press PTT and see if it shows debug messages in the debug window when you press and release PTT.
By Alex Amorianos 838329
#532332 Try also to go to Settings>Privacy>Microphone

At the top of the window, check that it says “Microphone access for this device is on.” If Windows says microphone access is off, click the “Change” button and set it to “On.” If access is off, Windows and all applications on your system can’t access audio from your microphone.
By Ross Carlson 887155
#532333 If the TX doesn't light up, I don't think it's a microphone problem. Seems it's not recognizing the PTT or he's not connected to a voice room.

Erich, let me know about the debug output. Also, does the frequency show in a light blue color at the top right corner of the vPilot window?
By Kenneth Haught 1067681
#532347 Actually following up on what Ross put...what are you trying to use as your PTT? If I recall there are some keys that won't recognize as PTT due to conflicts in the SIM/computer.
By Erich Berner 834484
#532390
Ross Carlson 887155 wrote:If the TX doesn't light up, I don't think it's a microphone problem. Seems it's not recognizing the PTT or he's not connected to a voice room.

Erich, let me know about the debug output. Also, does the frequency show in a light blue color at the top right corner of the vPilot window?


Hi Ross,

I'll try the debug tonight. I've been away for the past two days.

The active freq is in light blue font yes. Also, when I switch to an active freq, the active freq audio chime sounds. When I switch to an inactive freq, the inactive chime sounds.

The microphone is definitely set to 'on' in the Windows settings, and apps have access to it.

I have a PFC Yoke and the PTT is set to Button 7 on the yoke, as it has been for the past 5 years. I've tried re-assigning the PTT to a keyboard key, but get the same nil result.

Also tried uninstalling/re-installing vPilot.

cheers
erich