By Ross Carlson 887155
#498945 I'm looking for some brave souls to try out the vPilot 2.0 beta version. I say "brave" because nobody aside from myself has run version 2.0 yet, and it incorporates some major changes. You can expect that there will be bugs, probably show-stopping bugs that will make it unusable until I have a chance to fix them. Such is the case with untested software.

That being said, I would very much appreciate the help from anyone willing to give it a try and report your feedback.

Please make a backup of your existing installation in case you need to revert back to it. The existing installation can be found here:

%LOCALAPPDATA%\vPilot

The 2.0 installer lets you change the installation folder, so you can always put it in a different spot if you don't want to overwrite your existing 1.0 installation. However, I would prefer that you let it overwrite your existing installation in order to test that it properly upgrades your existing configuration file the first time you run version 2.0.

Here are the docs for version 2.0:

http://vpilot.metacraft.com/Documentation2.aspx

Here's a description of the major changes with some anticipated FAQs:

http://vpilot.metacraft.com/UpgradingV1toV2.aspx

Finally, here's the link to download the version 2.0 open beta installer:

http://vpilot.metacraft.com/DownloadHan ... 2.0.11.exe

Please create a new thread here in the vPilot forum if you run into any issues.

Thanks for the help!
By Ernesto Alvarez 818262
#499000 worth noting for PMDG and other payware aircraft users, you might want to disable these models in the advanced settings so they arent part of your model matching. otherwise your frames may come crashing or the sim itself. be warned
By Ross Carlson 887155
#499001 It won't make use of the PMDG models because they aren't part of the model database, and it can't determine the aircraft type and airline code by parsing the aircraft.cfg data.

The same may not be true of other complex add-ons, though.
By Ross Carlson 887155
#499008 Yes, it is, as long as you put them in different folders. The shortcuts created in the start menu and on the desktop will only point to the most recently-installed one, though.
By Bahaeddine El-Zarif 1123672
#499009 Ross,

Please advice on the tower view. Do you launch vpilot and use the dot command or is there a specific way to connect FSX with Euroscope?
By Bahaeddine El-Zarif 1123672
#499013
Ross Carlson 887155 wrote:Yes, launch vPilot and use the dot command. Refer to the Euroscope docs on how to set it up as the server.


Thank you!
By Marcelo Duran 1176670
#499065 Hi Ross.

Thanks for the new version.

Some issues here:

1. Cant't start in debug mode. Shortcuts pass an invalid command line argument... "-mmlog". If I delete it, debug mode works as expected. This one is easy to fix... :D

2) Networked configuration. Set IP on remote computer... default port 8809 on both sides... Start host first then remote app... then remote app hangs with message:

Unhandled exception: value can't be null.
Parameter name: key

or something like that... It's in Portuguese, since my windows is also in Portuguese.

On the host side, I have the following log:

[11:35:24.001] vPilot version 2.0.0.0
[11:35:25.381] Simulator connection failed.
[11:35:27.960] Attempting simulator connection...
[11:35:30.380] Simulator connection failed.
[11:35:32.962] Attempting simulator connection...
[11:35:35.378] Simulator connection failed.
[11:35:36.849] Remote connected: 192.168.0.21:49722
[11:35:36.879] Remote disconnected.
[11:35:37.962] Attempting simulator connection...
[11:35:40.382] Simulator connection failed.

Just for the record... my FSX was not running yet (and it didn't matter, actually).

As you can notice, port number is different from the one I set on both applications and each time I run vPilot, I get a error log message with a different port number.

I tried to set Firewall off, too. No success.

Let me know if you need more information.

Marcelo Duran.