By Jeff Thomas 812289
#530985 Two issues, and I have read a lot of articles and can't seem to resolve them.

1) Mode-C will not stay lit on the ground for me no matter what I do. I have a standard CRJ panel that comes with FSX on a ERJ145 from Posky so there is no mode button in the panel. So not sure where to turn it on and off because the vpilot button doesn't do anything but turn green then shut off. Not sure what to do there.

2) Voice just dies after 5 minutes or less. I've opened up all the ports on my routers and firewalls.


Since FS-INN appears to be dead as well (at least it won't even connect to FSX any longer).

What are my alternatives now? Go back to squawkbox?

Thanks for any insight.

Jeff
By Jeff Thomas 812289
#530999 So, after reading the FAQ above, I ran it as admin on my Win10 machine and I was able to squawk mode C on the ground. Vox still "paused" with windows firewall disabled and AVG disable completely.

I did forget to mention my stack

Windows 10
FSX
Active Sky
vasFMC

that's it. I don't run a ton of add-ons either.
By Jeff Thomas 812289
#531000 I figured the Mode C issue.

In vasFMC, under the MCDU MENU, click the SQUAWKBOX option, then switch it from AUTOMATIC to MANUAL.

No wonder sometimes I got it working then didn't whenever vasFMC was on. :wink:

Now if I could just get the VOX working correctly.
By Don Desfosse 1035677
#531008 Hi Jeff, I know you said you opened up "all" ports, but there are tens of thousands of ports in various flavors (UDP, etc.). Can you double (triple? :) ) check to ensure UDP port 3290 is forwarded. You said you totally disabled firewall and AVG, so assuming those aren't the problem (though would encourage you to still try in Win10: Windows Settings > Network and Internet > Windows Firewall > Allow an App Through Firewall > (Admin Icon) Change Settings > scroll down to vpilot.exe > ensure both Private and Public are checked). The only other thing I can think of is ensuring uPNP is DISABLED in your router. Can you check that? Maybe try that first, since you said you tried the others, but then just go back and double/triple check those.
By Ross Carlson 887155
#531019
Jeff Thomas 812289 wrote:2) Voice just dies after 5 minutes or less. I've opened up all the ports on my routers and firewalls.


Note that there is a difference between "opening" a port and "forwarding" a port. Most of the time, opening the port is not necessary, unless your firewall is configured to block ALL ports for outgoing connections by default, and you have to open them one by one. This is very rare. And if voice works at all, the ports are open.

If voice stops working after a while, that usually means the connection is closing (timing out) after a period of inactivity, and that is very common. Usually forwarding port 3290 UDP to the vPilot computer takes care of that issue.

Does voice stop working after you haven't pressed your PTT for a while?