By Christian Herhaus 1442523
#531265 I am affeceted by the issue that vPilot does not detect my mike and PTT button if not run as administror. Interestingly, I do NOT run FSX as administrator (I run it under a normal user account but followed Aerosoft recommendation to always install(!) all FSX-related software by "run as administrator").

When I run vPilot as administrator, this solves the PTT issue but now conflicts wiht FlyInside for Oculus Rift: Importing the vPilot window into the FlyInside virtual cockpit causes a crash while window import nicely works when vPilot is run in normal user mode. So, I can either import vPilot into FlyInside but without PTT, oder I can run PTT but not in Flyinside.

Solution could be to find access of vPilot to mike and PTT wihout administrator mode. Any idea for this?

Thank you!
By Ross Carlson 887155
#531266 Is the Oculus and FlyInside software running as an administrator?

Also, are you using a keyboard key or a joystick button for PTT?
By Christian Herhaus 1442523
#531272 Oculus and FlyInside/FSX are running as normal user, explicitly not using "run as administrator".
I assigned a joystick button to PTT.

Thanks for the very quick reply!
By Christian Herhaus 1442523
#531306
Ross Carlson 887155 wrote:Does PTT work if you run vPilot as a normal user outside of flyinside?


I systematically tested the possible cases. For the matter of ease (avoids connection to Vatsim) I applied the "Calibrate mic..." as surrogate for the PTT button issue because if PTT does not work, also the microphone calibration does not work but only returns "SpeechDrownedOut".
- FSX in normal mode, vPilot in normal mode: No calibration
- FSX in normal mode, vPilot in admin mode: Calibration, speech returned
- FSX in admin mode, vPilot in normal mode: No calibration
- FSX in admin mode, vPilot in admin mode: Calibration, speech returned

FlyInside first regularly starts FSX in windowed mode, then adds the layer for Oculus Rift support in the back:
- FlyInside/FSX in normal mode, vPilot in normal mode: No calibration
- FlyInside/FSX in normal mode, vPilot in admin mode: Calibration, speech returned

I cannot start FlyInside/FSX in admin mode. So, diagnostics is the same for FSX with or w/o FlyInside. vPilot in any case requires to be run in admin mode. This is the issue I need to solve, I need to run it somehow in normal mode (because if run it admin mode, FlyInside will crash when importing the vPilot window into the virtual cockpit).
By Ross Carlson 887155
#531307 It sounds like this is much more than a PTT issue, because you're saying you can't calibrate your mic, which has nothing to do with PTT. It sounds like vPilot cannot access your audio device. I think you'll need to bring this up with the flyinside devs to see if they have any suggestions. However, vPilot uses VVL (Vatsim Voice Library) to access your audio hardware, and VVL is not something I wrote or have the ability to modify, plus VATSIM is moving to a new voice system soon anyway, so we're not going to spend any time working on VVL. So you may be out of luck for now.
By Christian Herhaus 1442523
#531309 You gave me a hint for a part of the solution:
As said, FlyInside does nothing more than opening FSX (in windowed mode) but adds a layer of drivers for the Oculus Rift. So, the issue is linked to connection between vPilot and FSX, not FlyInside. But, knowing now from you that microphone access is separate from PTT, I had an idea: I checked Win10 security settings and noticed that mic access was deactivated for Apps. Activating solved the mic issue: I can now calibrate the mic in vPilot normal user mode! :)

I will dig deeper into this direction. Can you eventually tell me which files handle the VVL? I may try to extend access rights for these files, maybe this will be of help.
By Christian Herhaus 1442523
#531310
Christian Herhaus 1442523 wrote: Can you eventually tell me which files handle the VVL?

Sorry, I meant: Can you eventually tell me which files handle the PPT?
By Christian Herhaus 1442523
#531340 ISSUE SOLVED!

It was the Win10 security setting which blocked the microphone. So, it was the microphone blocking PTT and not PTT blocking the microphone.

Thanks again for all quick support and the right hint to the solution!