By Michael Williams 850131
#533134 Running Win 10; P3Dv4.5 ; Vpilot vers 2.2.2
Keep getting "Simulator connection failed".
Yes I have installed the FSX files, Prepar3D\redist\Interface\FSX-SP1\retail\lib\SimConnect.msi
Yes do have firewall permission.
No, external virus detection running.
Problem occurred after P3D update from 4.1 to 4.5.
Any help would be appreciated unless there is another client software available for P3D??

Regards Mike.
By Ross Carlson 887155
#533137 The simconnect library that you need is actually this one:

\redist\Interface\FSX-SP2-XPACK\retail\lib\SimConnect.msi

Not the SP1 version you listed.

However, if you have the wrong version of SimConnect installed, I would suspect that you'd get a different error, something like "version mismatch" or "SimConnect not found". So I'm guessing you have both versions installed. (Especially if it worked fine with P3D 4.1) Go ahead and install the SP2-XPACK version anyway, just so that we can eliminate that as a possible cause for the issue.
By Michael Williams 850131
#533146 Installed all of the simconnect files in redist/, restart, same problem , Simulator connection failed.
Attemting simulator connection every 10 seconds.
ProAtcX also refuses to connect.
ASN16 is fine.
FSeconomy is fine.
SpadNext is fine.
Thanks Ross, Mike.
By Ross Carlson 887155
#533148 Are you 100% sure the firewall isn't the issue? Have you tried temporarily disabling it?

Other than that I don't know what's blocking it. vPilot works with v4.5 for other users.
By Michael Williams 850131
#533149 Disabled firewall, uninstalled Vpilot, reinstalled as admin, same problem, unable to connect.
I'll give it a miss and go onto swift.
Thanks for your help been at this for two weeks now obviously my computer is preventing it from working.
Ive had Vpilot working for years with FSX and p3d.
Thanks Ross.
Mike.
By Michael Williams 850131
#533210 Hi Ross, Yes results below.
1. C:\Users\Mike Williams\AppData\Local\Apps\2.0\HL426Z94.0OYN\LBNWEG07.A08\fsec..tion_1d3d736 etc, etc SimConnect.cfg type CFG Date mod 21-May-19 Size 59 bytes

using notepad== it looks like this
SimConnect]
Protocol=IPv4
Address=127.0.0.1
Port=6700

2. E:\AS_P3Dv4\SimconnectFiles type CFG Date modified 03-Jul-07 Size 101 bytes
Using notepad++ it looks like this,
[SimConnect]
Protocol=IPv4
Address=myserveraddress
Port=500
MaxReceiveSize=4096
DisableNagle=0




3. C:\Users\MikeWilliams\Documents type CFG Date 17-May-19 size 412 bytes.
Using notepad++ it looks like this,
[SimConnect]
Protocol=IPv4
Address=192.168.23.107
Port=500
MaxReceiveSize=4096
DisableNagle=0

[SimConnect.1]
Protocol=IPv4
Address=192.168.23.107
Port=6811
MaxReceiveSize=4096
DisableNagle=0

I will do the ini files in the morning .
Good night,
Mike.
By Michael Williams 850131
#533220 No I did not create any of these files.
Single machine use only.
By searching my C: drive for "vPilot" I have found 58 items listed. Wish I knew how to post a picture?
4 are of concern,
vPilot C:\Windows.old\Users\MikeWilliams|AppData\Local..........its the 'Windows.old'

vPilot C:\Windows.old\Users\Mike Williams\AppData\Roaming\Microsoft\windows\Start MenuPrograms…...etc Again 'Windows.old'

vPilotConfig C:\Windows.old\Users\Mike Williams\AppData\Local\vPilot\vPilotConfig.xml
which opened in notepad looks like this

<FullName>Mike Williams</FullName>
<HomeAirport>YBUD</HomeAirport>
<PTTConfiguration DeviceType="None" ButtonOrKey="0" />
<InputDeviceName>Wave - Headset Microphone (Microsoft L</InputDeviceName>
<OutputDeviceName>Wave - Headset Earphone (Microsoft Lif</OutputDeviceName>
<OutputVolume>75</OutputVolume>
<MicSquelch>200</MicSquelch>
<EnableVHFSimulation>true</EnableVHFSimulation>
<AircraftVisualRange>40</AircraftVisualRange>
<MaxRenderedAircraft>999</MaxRenderedAircraft>
<SquawkingModeC>false</SquawkingModeC>
<AutoSquawkModeC>false</AutoSquawkModeC>
<RecentConnectInfo>
<ConnectInfo Callsign="MAW" TypeCode="B350" SelCalCode="" ObserverMode="false" />
</RecentConnectInfo>
<FlashTaskbarPrivateMessage>true</FlashTaskbarPrivateMessage>
<FlashTaskbarRadioMessage>true</FlashTaskbarRadioMessage>
<FlashTaskbarSELCAL>true</FlashTaskbarSELCAL>
<FlashTaskbarDisconnected>true</FlashTaskbarDisconnected>
<ShowIncomingTextInFSX>false</ShowIncomingTextInFSX>
<LastFlightPlanFilterIndex>1</LastFlightPlanFilterIndex>
<LastFlightPlanFolder>C:\Users\Mike Williams\Documents\vPilot Files</LastFlightPlanFolder>
<CheckForUpdates>true</CheckForUpdates>
<UpdateChannel>Stable</UpdateChannel>
<EnablePTTBuzzer>true</EnablePTTBuzzer>
<PlayMessageNotificationOnHost>false</PlayMessageNotificationOnHost>
<ShowIncomingMessagesOnHost>false</ShowIncomingMessagesOnHost>
<ControllerListFont Family="Microsoft Sans Serif" Size="9" Style="Regular" />
<TextMessagesFont Family="Courier New" Size="9.75" Style="Regular" />
<MainSplitterDistance>171</MainSplitterDistance>
<HostAddress />
<HostPort>8809</HostPort>
<ModelMatchingConfigs>
<ModelMatchingConfig>
<SimulatorType>Prepar3dV4</SimulatorType>
<DefaultModel>Bombardier CRJ 700</DefaultModel>
<CustomModelMatchRuleSets />
<ErroneousModels />
</ModelMatchingConfig>
</ModelMatchingConfigs>
<ModelMatchRuleSets />
<DefaultModel>Airbus A321</DefaultModel>
<CustomModelMatchRuleSets />
<SimulatorType>None</SimulatorType>
<ErroneousModels />
</vPilotConfig>

Hope this helps because I am getting confused again.
Regards Mike.