By Mohamed Hammouna 1291174
#535913 Hi,

I have been using the Aerosoft A318/19 Professional (P3D v4) for some time now, but recently I started to get this strange bug where my altitude gets transmitted to the Vatsim servers incorrectly by usually -1000 feet. This makes it not just challenging for me, but also for ATCs and surrounding TFC as they see me 1000 ft lower than I actually am.
And no, this is not because of a wrongly set altimeter ...
I have already de-installed the bus and installed it again as well the vPilot client.

Hope anyone can provide a solution for this.

https://prnt.sc/p9t5bk

https://prnt.sc/p9t5lj
By Ross Carlson 887155
#535916 Are you basing this on what that map shows, or have you also had reports from actual controllers that you are off by 1000 feet?
By Ross Carlson 887155
#535937 No, I don't suspect a problem with your weather engine. The reason I ask is because all VATSIM pilot clients send two altitudes to the server. One is your pressure altitude, the other is your true altitude. I'm not sure which of those your map screenshot is showing. Knowing the ambient pressure at the time might help explain it. I also know that the controller's scope might show the wrong altitude (pressure vs true) if it is not configured right.
By Mohamed Hammouna 1291174
#535938
Ross Carlson 887155 wrote:No, I don't suspect a problem with your weather engine. The reason I ask is because all VATSIM pilot clients send two altitudes to the server. One is your pressure altitude, the other is your true altitude. I'm not sure which of those your map screenshot is showing. Knowing the ambient pressure at the time might help explain it. I also know that the controller's scope might show the wrong altitude (pressure vs true) if it is not configured right.


Thank you for your help. I will have a look.