By stephen avery 1438077
#536079 hello!, i have recently upgraded to the new version 2 and now my planes are white and the model matching isnt recognized, i now have the two sims listed fsx and fsx se, and it wont lwt me select fsx (that was working for the previous version), i think its confused as all folders etc point to fsx and not fsx se...........even though fsx steam is what loads with dovetail right!!!, anyway to fix this or to choose fsx?? i thought this was automated, i havent moved any folders etc e.g. vpilot .vmr files by flai are still in the roht spot!.......thanks on advance, in the mean time ive rolled back to the working earlier verison. :shock:
By stephen avery 1438077
#536129 ]i have fsx steam that runs but it uses the fsx file which is a bit odd but steam loads.......they both have the same folder pathway so may be confusing vpilot.

it works fine with verison 2 and just the fsx selection...see screenshots showing 0 model match, hopefully you can access this link as the forum wont let me upload pics?

https://www.dropbox.com/sh/kr0kyiqtwxaf ... h6L_a?dl=0
By stephen avery 1438077
#536209 https://www.dropbox.com/s/x9poqfexpphmx ... 2.JPG?dl=0

see here for version 2.0, my theory is in the latest version where it has the 2 choices for model matching something is conflicting, if you look at the vatsim facebook forum im not the only one with the issue with the update.

thanks!! steve
By Ross Carlson 887155
#536210 vPilot doesn't care if they both point to the same folder. The problem is that your FSX:SE installation doesn't have any model sets installed, so the vPilot model matching code has no models to work with.

When you run the sim, how do you actually go about launching it?
By stephen avery 1438077
#536218 i can launch either the fsx or fsx se exe file and steam lanches no matter what, i have all the models installed as i have no issue with version 2.0, for example there is only 1 documents vpilot folder with the .vmr in it so why cant it see it, i thought this was automatic?

i guess ill never update to keep it working for me. there are others that are having the same issue oddly enough,
By Ross Carlson 887155
#536219 Stephen, please open this folder in a windows explorer window:

Code: Select all%appdata%\Microsoft\FSX-SE


Within that folder you should see a file called fsx_se.CFG

Open that file in a text editor, and search for lines starting with SimObjectPaths

Do you find any such lines?
By Ross Carlson 887155
#536260 Okay, great. I would like to modify vPilot so that it properly detects this situation where you have FSX and FSX:SE both pointing to the same folder. It would be helpful for me to know the simulator name that vPilot detects when you run it. Can you look at the startup messages and tell me exactly what it shows in the line starting with "Connected to simulator." ? For example, mine says:

[15:07:38] Connected to simulator. (Lockheed Martin® Prepar3D® v4)