News and Forum Instructions
By Tommi Karkkainen 1322309
#536464
Lars Bergmann 1357290 wrote:Swift already has released an alpha with AFV support: https://dev.swift-project.org/phame/pos ... t_and_afv/


That's very nice! Although I don't think it's desirable that all Mac and Linux pilots apply for development/testing access to VATSIM, as is needed to use the Alpha version. Especially, if the reason for the request is to get a one-time ok for a specific version. But this does give hope that an approved beta will be out soon.

My understanding is that flying text only (using xSquawkbox and no AFV client) is absolutely possible (though certainly not desirable :D)


I can imagine it's not desirable. But if it's all that works...
(Shouldn't text-only with Swift work all the same as xSquawkbox without AFV?)
By Matthew Bartels 863645
#536467 Swift have released a public alpha.

https://dev.swift-project.org/phame/pos ... t_and_afv/
By Tommi Karkkainen 1322309
#536475
Matthew Bartels 863645 wrote:Swift have released a public alpha.

https://dev.swift-project.org/phame/pos ... t_and_afv/


I didn't realize that this actually is a public alpha. There was some outdated information on the Swift site regarding what alpha versions are and who gets to use them on the network. That's where my confusion came from.

Anyway, I'm happy, at least for now. Fingers crossed that there aren't too many bugs :)
By Matthew Purves 1202432
#536484
Roberto Negron 852648 wrote:Disappointing for us MAC users. Today I downloaded the so called "stand alone client" for xsquawkbox and guess what....I need fracking Parallels to even open it up after download. I figured that you would consider the whole community as you go forward with this but NO....As always MAC users are being discriminated against. It just shows lack of vision, commitment, and just plain laziness. This was supposedly years in the planning. In that timeframe.... Nobody thought about soliciting volunteers, hiring (for lack of a better term at this time)a MAC expert that could possibly help with coding, integration so that all of us could enjoy VATSIM? I will tell you this. If you don't start getting with the times, Pilot Edge will displace you as a network, at least in the US. Now ....after this rant if someone has a workaround for this let me know. You have to forgive me but since the initial email almost 2 weeks ago I was so looking forward to this and BOOM; felt like a door shut right in your face. :( :twisted:


+1!! I have been using Vatsim with voice successfully on my Mac with xsquawkbox and X-plane for years and now - "It's just for Windows". A massive smack in the mouth. I am bitterly disappointed and angry.
By Matthew Bartels 863645
#536485
Matthew Purves 1202432 wrote:
+1!! I have been using Vatsim with voice successfully on my Mac with xsquawkbox and X-plane for years and now - "It's just for Windows". A massive smack in the mouth. I am bitterly disappointed and angry.


Relax... You've not been forgotten about. Full xplane support on all non windows operating systems is coming rapidly. Those devs are working extremely hard and we could even have functionality for both before we even come back online Monday :)
By Gary Oliver 811521
#536530 If you take a look at the Swift Discord you will see that the swift team are actively trying to resolve the small bug preventing Mac users from running the beta.

Thanks again to Roland and the team for the epic work with a cross platform implementation of the AFV client. He has been an absolute hero in keeping up with all our changes and not complaining.

Hopefully come Monday morning all our cross platform friends will be happy.

Cheers
Gary
AFV Lead
By Nikola Jovanovic 951874
#536654
Tom David 1256094 wrote:How will frequencies like 122.8 121.5 and 123.45 be moderated? Im curious considering the new codec wont have rooms like melp does.


You should listen 123,45 irl. People fart, burp, meow... it's unbearable to listen. 121,5 as well.
By Chris Knipe 920540
#536706
Matthew Bartels 863645 wrote:I would implore those who are still on FSINN or Squawkbox to start learning swift now if you are not planning to change from FS9. Regardless of how you feel about swift, that will be your only option to continue to use FS9 very soon.


Swift, is bloatware - full of nonsense that is not needed. It's trying to do a little bit of everything, instead of doing one thing good. Say what you want. Sorry, but I've used Swift, I hated it, I will never use it - unless the entire GUI -drastically- changes.

If VATSIM is for one second thinking to "force" swift down everyone's throat then I'm sorry. Bye bye VATSIM.

My 2c. Use it, don't use it. Keep your flames for yourself, as I really don't care.
By Nestor Perez 1369273
#536708 Well, that's a good attitude, isn't it? It's not that VATSIM's forcing it down your throat, but rather that it's your only option currently available. If you want to make a new pilot client to support it, I'm sure Zach is anxiously awaiting a message in his inbox :)
By Chris Knipe 920540
#536709
Nestor Perez 1369273 wrote:Well, that's a good attitude, isn't it? It's not that VATSIM's forcing it down your throat, but rather that it's your only option currently available. If you want to make a new pilot client to support it, I'm sure Zach is anxiously awaiting a message in his inbox :)


So I guess vPilot's also not being maintained? Even though they pushed how many updates and new versions over the last few months? I think at least 4, or 5 if memory serves me correctly? I will rather fly on IVAO, than use Swift.

It's been discussed time, and time again in the past. There's HUNDREDS of ways, in which you can get devs interested to develop software to be used on VATSIM. It's VATSIM that chooses to be restrictive, not the devs. I personally, tried numerous times in the past (just like many others), and quite frankly, I got tired of trying to just get basic information...

Open your documentation and APIs up, see what happens... If you dare.

Oh, and congrats on AFV - looking forward to it tonight when I get home from work.
By Nestor Perez 1369273
#536714 What does vPilot have to do in this conversation?

Swift is the only option that will be available for FS9 users, and I very much doubt any developer would want to use their time with such an outdated sim anyway.

Time doesn't stop ticking: individuals can stay behind if they want, but the rest of the network won't do the same unfortunately...

That's all there is to it.
By Gunnar Lindahl 967365
#536718
Chris Knipe 920540 wrote:It's been discussed time, and time again in the past. There's HUNDREDS of ways, in which you can get devs interested to develop software to be used on VATSIM. It's VATSIM that chooses to be restrictive, not the devs. I personally, tried numerous times in the past (just like many others), and quite frankly, I got tired of trying to just get basic information...


Chris,

How do you think Audio for VATSIM has been developed? hint: it's by devs.

When did you last attempt this? A lot has changed in 2 years. If you can get involved in building a client for Mac that meets your requirements, please get in touch with the team ASAP.