By Michael Feetham 1458998
#538332 When I set the xpilot audio output to my speakers, everything is fine. However, when I set output to my headphones, I no longer get audio. The Rx lights up, and other audio mutes slightly, but I don't hear anything. Radios are set correctly, as I can hear ATC and ATIS when I connect to speakers. I have verified audio from com1 AND com2 both work with speakers but not headphone output. Other computer audio is working on headphones without issue, including xplane.

Windows 10Home
x-plane 11 (latest version as of Oct 20, 2019)

xpilot 1.1.0.7
Last edited by Nestor Perez 1369273 on Tue Oct 22, 2019 1:19 am, edited 1 time in total. Reason: Moved to xPilot section
By Justin Shannon 1215759
#538383 Look at your xPilot configuration file (by default located in %localappdata%\xPilot) and see if the name of your headset device is getting truncated. If it is, try manually changing it to the full name and then launch xPilot and try again.
By Michael Feetham 1458998
#538419
Ernie Garcia 1392892 wrote:I am having the same issue, frustrating!! to the point that I am considering going back to IVAO or flying offline (which is basically the same thing :roll: ). Are you using the Logitech G633 by any chance?


I'm using the G433 Gaming Headset.
By Michael Feetham 1458998
#538420
Justin Shannon 1215759 wrote:Look at your xPilot configuration file (by default located in %localappdata%\xPilot) and see if the name of your headset device is getting truncated. If it is, try manually changing it to the full name and then launch xPilot and try again.


Justin,

There does not appear to be an xPilot folder in my local app folder. Can you give me the specific file name? I'll search for that.
By Justin Shannon 1215759
#538422
Michael Feetham 1458998 wrote:
Justin Shannon 1215759 wrote:Look at your xPilot configuration file (by default located in %localappdata%\xPilot) and see if the name of your headset device is getting truncated. If it is, try manually changing it to the full name and then launch xPilot and try again.


Justin,

There does not appear to be an xPilot folder in my local app folder. Can you give me the specific file name? I'll search for that.

Then it’s wherever you installed xPilot.
By Michael Feetham 1458998
#538430
Justin Shannon 1215759 wrote:Then it’s wherever you installed xPilot.


I have found the AppConfig.xml file in the installation directory (I chose a custom directory for install, not default).

Looking through that, I found this section.

<ToggleDisplayConfiguration ShortcutType="None" KeyCode="0" />
<InputDeviceName>Microphone (Voicemod Virtual Au</InputDeviceName>
<OutputDeviceName>Speakers (Logitech G433 Gaming Headset)</OutputDeviceName>
<DisableAudioEffects>false</DisableAudioEffects>

The OutputDeviceName appears to be correct (though the microphone looks truncated).
By Ernie Garcia 1392892
#538432
Justin Shannon 1215759 wrote:Look at your xPilot configuration file (by default located in %localappdata%\xPilot) and see if the name of your headset device is getting truncated. If it is, try manually changing it to the full name and then launch xPilot and try again.


Thanks for the reply. It doesn't seem to fix anything although it was truncated. I can hear the noise it makes when ppl type and stuff but same problem with receiving voice and ATIS like stated above and since he also has a G headset I'm assuming Vatsim is not made for the G series (and yes I have all drivers updated). Doing my last flight tonight in the "mute" sort-of-speak and then switching back to IVAO.
By Michael Feetham 1458998
#538477
Justin Shannon 1215759 wrote:Does the standalone AFV client work?


Uninstalled xPilot, installed xSquawkbox and the AFV standalone client.

Exact same result. Audio works when I select speakers as output, doesn't work when I select headphones.
By Justin Shannon 1215759
#538488
Michael Feetham 1458998 wrote:
Justin Shannon 1215759 wrote:Does the standalone AFV client work?


Uninstalled xPilot, installed xSquawkbox and the AFV standalone client.

Exact same result. Audio works when I select speakers as output, doesn't work when I select headphones.

If you open the settings and select your headset as an input device, does the mic level indicator bar move when you speak?
By Michael Feetham 1458998
#538523
Justin Shannon 1215759 wrote:If you open the settings and select your headset as an input device, does the mic level indicator bar move when you speak?


Yes, the microphone works.

Removed the Logitech headphones and uninstalled them. My son has SteelSeries USB headphones, so I tried those. Everything works 100%.

Uninstalled the SteelSeries, plugged Logitech headphones back in, forced a driver update and I'm back to the same problem.
By Michael Feetham 1458998
#538528 GOOD NEWS!

I downloaded the latest version of Logitech G Hub from the Logitech website. Installing the new software has resolved my issue. I have tested with xSquawkBox/AFV standalone client as well as wil xPilot. Not sure why this was different than the drivers alone.

Justin, thank you for all your due diligence and support.