By Kin-Shing Dave Tchang 814681
#540260 Hi,

I am getting regularly the following errors in the applications log of the Windows system logs:

Logboeknaam: Application
Bron: Application Error
Datum: 22/11/2019 11:04:38
Gebeurtenis-id:1000
Taakcategorie: (100)
Niveau: Fout
Trefwoorden: Klassiek
Gebruiker: n.v.t.
Computer: msilaptop
Beschrijving:
Naam van toepassing met fout: X-Plane.exe, versie: 11.0.40.12, tijdstempel: 0x5dbc2188
Naam van module met fout: xPilot.xpl, versie: 0.0.0.0, tijdstempel: 0x5dc2db08
Uitzonderingscode: 0xc0000005
Foutmarge: 0x000000000010eb79
Id van proces met fout: 0x2580
Starttijd van toepassing met fout: 0x01d5a11c2d9c8544
Pad naar toepassing met fout: X:\Laminar Research\X-Plane 11\X-Plane.exe
Pad naar module met fout: X:\Laminar Research\X-Plane 11\Resources\plugins\xPilot\win_x64\xPilot.xpl
Rapport-id: 9e6b4939-702b-4424-97b5-15991766b6d2
Volledige pakketnaam met fout:
Relatieve toepassings-id van pakket met fout:
Gebeurtenis-XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-11-22T10:04:38.271459600Z" />
<EventRecordID>46975</EventRecordID>
<Channel>Application</Channel>
<Computer>msilaptop</Computer>
<Security />
</System>
<EventData>
<Data>X-Plane.exe</Data>
<Data>11.0.40.12</Data>
<Data>5dbc2188</Data>
<Data>xPilot.xpl</Data>
<Data>0.0.0.0</Data>
<Data>5dc2db08</Data>
<Data>c0000005</Data>
<Data>000000000010eb79</Data>
<Data>2580</Data>
<Data>01d5a11c2d9c8544</Data>
<Data>X:\Laminar Research\X-Plane 11\X-Plane.exe</Data>
<Data>X:\Laminar Research\X-Plane 11\Resources\plugins\xPilot\win_x64\xPilot.xpl</Data>
<Data>9e6b4939-702b-4424-97b5-15991766b6d2</Data>
<Data>
</Data>
<Data>
</Data>
</EventData>
</Event>

Currently running xPilot version 1.1.5.0 with X-plane version 11.40r2 (build 114012 64-bit). Don't notice anything particular when running the software. Just noticed the above entries in the Windows log. Any ideas?

Thanks!

Kind regards,
Dave
By Kin-Shing Dave Tchang 814681
#540380
Justin Shannon 1215759 wrote:When this happens, does X-Plane crash? Does it happen each time you use xPilot?


Hi Justin,

Like I said in my previous post, I don't notice anything special when running the software. I only noticed it in the Windows application logs. X-plane and xPilot runs without any crashes or warning messages. Just wondering though why these log events are being generated in teh Windows logs.

This can also happen if the xPilot client software is NOT running. What I mean is the xPilot external EXE application. But then again the xPilot plugin (XPL) is always running, is it not.

Kind regards,
Dave
By Justin Shannon 1215759
#540464
Kin-Shing Dave Tchang 814681 wrote:
Justin Shannon 1215759 wrote:When this happens, does X-Plane crash? Does it happen each time you use xPilot?


Hi Justin,

Like I said in my previous post, I don't notice anything special when running the software. I only noticed it in the Windows application logs. X-plane and xPilot runs without any crashes or warning messages. Just wondering though why these log events are being generated in teh Windows logs.

This can also happen if the xPilot client software is NOT running. What I mean is the xPilot external EXE application. But then again the xPilot plugin (XPL) is always running, is it not.

Kind regards,
Dave

Unfortunately, I haven't been able to track down what exactly is causing these errors in the event log. Since it's not causing X-Plane to crash, I am not going to prioritize my time with trying to resolve it.