By Ernesto Alvarez 818262
#401310 ive noted this before. FSINN will completely ignore the model with the FSINN.cfg in the folder.

only way to fix that, take the fsinn.cfg out of the folder, itll start reading it again correctly.

now the issue you may run into is whenever FSINN uses that model as AI, youll have to manually change it by going to SET > PLA and click on the users callsign, then you can manually assign it a different model.

i wonder if theres an extra line you can add to the fsinn.cfg so itll ignore it as AI, but also let FSINN read it without putting it as ZZZZ.
By Robert Halmich 873302
#401390 First off, Peter Hornfeck has updated his program which can be found here:

http://nordenflieger.de/temp/AC_ICAO_45.zip

I now see UT2 traffic although I am not seeing the AC in their proper liveries, one AC was an MD-11 in US Airways which is understandable because they do not fly the MD-11 but the other was a Jetblue A320 so I am a little confused as to why it did not appear as it should... it is a start because I couldn't see any traffic prior to this.

I downloaded AC_ICAO_45.zip (newer version)
unpacked it in a new, clean folder
installed AI in a folder called PAI and WOAI and made the proper entries into the FSX.cfg (SimObjectPaths.X=SimObjects\PAI etc.) started flight sim, started FSInn, exact number of UT2 aircraft were listed and WOAI were not recognized
closed both programs
started AC_IDs.exe and followed the screen.

-Pressed PAI Registration
-Pressed WOAI Registration
-Pressed Ultimate Traffic 2 Registration

When I "register" the above packages I am not sure if they are all added to a registry DB and I am unsure as to whether one will cancel the previous selection out. I cannot find the DB in the FSFDT folder so I am at a loss.

I run FSInn via a network computer and when I start FSInn I see that it creates an AC list although the same number of AC remain and the content is not updated after all.

The AcftDB2-64.reg remains at 3.59Mb and has not increased in size and I am unsure if I should try to copy the reg entries over to the computer where FSInn is located.

I ran the exportregDB and was prompted to upload to upload.apollo3.com/upload but I am unsure as to whether that was necessary or not.

I am going to post over at the UT2 forums and see what they have to say about their liveries not showing.

Robert

2011 02 16 17:45z

**Edit** PAI and WoAI aircraft have now been recognized by FSInn (up to 3654 AC from 1716) but the aircraft are defaulting to UT2 Daedalus liveries. I'm hoping that Larry James will have a look at this post and let me know if I have to copy the AcftDB2-64.reg entries over to my PC where FSInn is running.
Last edited by Robert Halmich 873302 on Wed Feb 16, 2011 11:47 pm, edited 10 times in total.
By Pan Lalas 936402
#401526 I wonder if the following FSINN.cfg for the payware addons would change anything:
[FSINN]
IGNORE=0
CSL=0

It's just a guess, but would this extra line allow FSINN.cfg to detect the payware addons and not add them to the repository?
Thoughts?
By Robert Halmich 873302
#401579
Pan Lalas 936402 wrote:I wonder if the following FSINN.cfg for the payware addons would change anything:
[FSINN]
IGNORE=0
CSL=0

It's just a guess, but would this extra line allow FSINN.cfg to detect the payware addons and not add them to the repository?
Thoughts?


Hi Pan,

What is the desired final outcome? IGNORE=0 would allow payware to be included in the repository, what does CSL=0 mean?
By Jan Tore Elvheim 835974
#404004 I have tried this manual, and I keep failing.

I have rescanned my library with fsinn(have downloaded all IVAO aircrafts)
Running the AC_ICAO tool(tried both version 16 and 39. I have tried running this both after and before FSarf)
And running FSarf. The problem is that I keep getting 0 aircrafts in database when Analyzing Registery.

I tried one time setting some aircrafts manually via fsinn when online, this resultet in registry analyzing finding 3 aircrafts.

Any suggestions on what I am doing wrong?


Would love to have FSinn working with auto selected liveries :oops:
By Robert Halmich 873302
#404022
Jan Tore Elvheim 835974 wrote:I have tried this manual, and I keep failing.

I have rescanned my library with fsinn(have downloaded all IVAO aircrafts)
Running the AC_ICAO tool(tried both version 16 and 39. I have tried running this both after and before FSarf)
And running FSarf. The problem is that I keep getting 0 aircrafts in database when Analyzing Registery.

I tried one time setting some aircrafts manually via fsinn when online, this resultet in registry analyzing finding 3 aircrafts.

Any suggestions on what I am doing wrong?


Would love to have FSinn working with auto selected liveries :oops:

Hi Jan,

As I mentioned above, Peter Hornfeck has updated his program which can be found here:

http://nordenflieger.de/temp/AC_ICAO_45.zip

I run FSX so my steps do not apply to FS9. I started by first uninstalling FSCopitlot/FSInn and deleted the ICAO DB in the registry and then proceeded with a fresh installation of FSCopitlot/FSInn. That was the only way I could get FSARF to recognize more than 10 AC.

Start FS and FSInn then close both programs. Run AC_ID,exe and "Register" the "Activate" your AI packages, exit and start FSARF. Please note that I re-ran FSARF to create a .reg entry for my 32bit PC as I run all my background programs on a second PC. If you run everything on the one computer then simply run FSARF once.

Below is my reply in the FSARF post from page 3:

viewtopic.php?f=43&t=52496&start=30
I decided to start fresh and reinstalled FSCopilot/FSInn onto my FSX PC running Vista 64 and reinstalled FSCopilot/FSInn on my XP 32 PC , ran the AC_ICAO tool and FSARF which created a new .reg entry which I double-clicked to add it to the registry. I then ran through the process a second time in order to convert the .reg so AC are recognized while running FSInn on the networked PC:

Step 1 Pressed "Analyze FS Aircrafts"; navigated to FSX\SimObjects where my AI is located and analyzed the entire folder.
"Start Analysis" 6268 variations found, pressed "OK"
Step 2 Pressed "Analyze Registry" Reader presented me with a registry location, this is where I converted it by pressing "FSX 32bit" and pressed "Start analysis"... "Analysis complete"..."Total 3700 aircrafts in registry" pressed "OK"
Step 3 Pressed "Auto Assign Aircrafts" selected 1 Fully Automatic, pressed "Begin the process" and the assignment completed and I pressed "OK"
Step 4 Pressed "Export Results"... presented with a list of AC and pressed "Export" then saved the file to run on the XP32 PC.

And that is it, most if not all AC are assigned with the proper types and liveries. A big thanks to Vladislav for presenting this tool to us.

Robert

For what its worth, I created an entry for my IVAO package and placed it first in mt FSX.cfg

[Main]
User Objects=Airplane, Helicopter
SimObjectPaths.0=SimObjects\IVAO MTL
SimObjectPaths.1=SimObjects\UT2 Aircraft
SimObjectPaths.2=SimObjects\Airplanes
SimObjectPaths.3=SimObjects\Rotorcraft
SimObjectPaths.4=SimObjects\GroundVehicles
SimObjectPaths.5=SimObjects\Boats
SimObjectPaths.6=SimObjects\Animals
SimObjectPaths.7=SimObjects\Misc

I found that manually changing AC liveries through FSInn was useless as they did not stay in the respective ones that I chose and moreover the process is extremely time consuming. Hope this helps.
By Jan Tore Elvheim 835974
#404031 Thank you for trying to help. Did another try, but it didn't work now either. Ill have to manually select for now I guess.

I run W7/64bits. Run in Admin mode/UAC turned off...

Did an uninstall of fscopilot/fsinn and cleaned the registry.

Reinstalled copilot/fsinn and started fs9. The aircrafts was scanned. Closed FSinn/FS9. Started AC_ICAO_45.
Pushed IVAO registration. It did its thing. Pressed Activate on IVAO. Exited AC_ICAO. Ran FSARF, Analyzed aircrafts, 5044 available.
Pressed Analyze Registry, changed to FS9 64bits, result was as before "Total 0 Aircrafts in Registry."

Ill try some different approaches. It seems that maybe AC_ICAO doesn't gets it work saved in the registry or something?

EDIT:
I have manually selected a default for every aircraft type in fsinn and now I get 33XX results in FSARF so Im in business now
By Robert Halmich 873302
#404059
Jan Tore Elvheim 835974 wrote:Pressed Analyze Registry, changed to FS9 64bits, result was as before "Total 0 Aircrafts in Registry."

Ill try some different approaches. It seems that maybe AC_ICAO doesn't gets it work saved in the registry or something?

EDIT:
I have manually selected a default for every aircraft type in fsinn and now I get 33XX results in FSARF so Im in business now

Jan from what I have read FSARF should not have to be changed to output to a 64bit reg as it will apply the .reg as per the OS speed.

Someone please correct me if I am wrong.
By Graham Kinnear 977713
#406273 Hi, I'm having the same problem as Jan. I have about 3700 aircraft in my aircraft folder but when it scans the registry it only says I have 7 aircraft?

Please could you explain what you did step by step to get it to work. I've tried matching every aircraft type I have to any aircraft (all Beechcraft 58) in ICAO Custom. I'm not sure if thats what you did though?

Any help would be great!

Many Thanks,

Graham.
By Kevin Burns 1111491
#411079
Graham Kinnear 977713 wrote:Hi, I'm having the same problem as Jan. I have about 3700 aircraft in my aircraft folder but when it scans the registry it only says I have 7 aircraft?

Please could you explain what you did step by step to get it to work. I've tried matching every aircraft type I have to any aircraft (all Beechcraft 58) in ICAO Custom. I'm not sure if thats what you did though?

Any help would be great!

Many Thanks,

Graham.


Same for me. I don't understand what he means by:
EDIT:
I have manually selected a default for every aircraft type in fsinn and now I get 33XX results in FSARF so Im in business now


Any help is appreciated.

Regards,
Kevin B
By Warren Alexander 1151793
#412474
Larry James 901346 wrote:
Ian Beggs 1005752 wrote:I did every step word for word and have almost 6000 aircraft in my DB for fsinn to choose from but while online its always the default lear or soar airlines md80


Follow the steps provided in the FAQ linked in the installation sticky that describes your issue and itemize what you actually did and you won't have this problems.

Hi Larry

I tried to find the above from the FAQ but couldn't find it. The instructions given to see other traffice seems really complicated and I would def welcome an easier way to accomplish it. Could you plse be more specific. Big thank you, Warren