By GIORGIO Tresoldi 967456
#515980 Hi,

I am experiencing a strange problem. Until a couple of weeks ago everything was fine. Now when I start ES (I tried a clean install and the latest beta), I can connect to Sweatbox and even start a simulator session. I can also connect to a VATSIM server using a callsign that is already in use (I get the usual error), but every time I connect to a VATSIM server with a callsign which is not yet in use and the connection is successful, I get a fatal error that makes ES crash.

I also tried what was described here viewtopic.php?f=71&t=64876 without luck

Here you can find the dump files:

Thank you in advance!

By Jonas Kuster 1158939
#516034 I had also a similar issue on my windows 7 machine, but most probably due to some problems with the .net framework libraries.
But my issue is restricted to stations using center facility. So just to check any similarities, did you also try to login as different facilities?
By Jonas Kuster 1158939
#516345 Tested again and have now the crash also (again) with the latest r15. Release r10 and earlier does work. Later releases cause a crash after the connection just has been established. However, for me it only applies to _CTR stations (facility Center set) and higher, so CTR and FSS. For APP everything works fine.
Unfortunately, no crash dump is created in such a case. It seems the crash is that fatal not even the error handler is able to collect data. I can however use the .crash command, but I don't know if the dump file from there helps anything. I've also the dump file created from windows, perhaps this can help something.
By Jonas Kuster 1158939
#516408 Just to give a few more details which might help for the investigation of this issue. My used configuration when experiencing this issue is Win7 Pro x64. If you need any information about further components or software, such as .net framework, I'll provide the required details with pleasure.
By Jonas Kuster 1158939
#516715 Thanks to the assisstance of Gergely, Giorgio and I were able to resolve the issue testing an intermediate release. I guess the fix will be part of the next public release.