By Andrei Borissovitch 858947
#520383 When you run EuroScope version 3.2.1.16 (3.2a (r16)), the plug-in settings are not restored.
The analysis of the xxxxx.asr file showed that the "END" entry is not created in the "VCCS" and "PLUGINS" blocks when it saving. If you add these entries to the settings file, then the settings are restored correctly.
By Jonas Kuster 1158939
#520420 Why would you need an END tag in an ASR file? Syntax there should be "PLUGIN:Pluginname:Settingname:Settingvalue". An END tag there is not required as far as I know. I know END tags only from the setting txt files. If you split them in separate ones (one txt file for each setting group), it shouldn't cause a problem. But I see that my files for VCCS and PLUGINS are missing the END tag as well. However, I've not noticed a functionality issue so far.

@Andrei: What plugin are you specifically talking about?
@Gergely: Can you confirm there is no END tag for VCCS and PLUGINS section and if there is any reason for it?
By Andrei Borissovitch 858947
#520428 @Jonas: I use "vTools". I rewrite it to the ES 3.2 class structure. But it does not depend on the plugin.
An additional check showed that the END is needed in any section that is located before the PLUGIN section.
A section PLUGIN may not have a tag END, you're right.
By Andrei Borissovitch 858947
#520429 In this case, everything is restored correctly:
Code: Select allVCCS
Ts3Server:localhost
Ts3Port:9988
END
PLUGINS
vTools:ACList/QFE/m_Visible:1
vTools:ACList/QFE/m_X:1298
vTools:ACList/QFE/m_Y:24

And in this - the list is displayed in the upper left corner of the screen:
Code: Select allVCCS
Ts3Server:localhost
Ts3Port:9988
PLUGINS
vTools:ACList/QFE/m_Visible:1
vTools:ACList/QFE/m_X:1298
vTools:ACList/QFE/m_Y:24