By Ashar Hussain 1374485
#528880 Hello everyone! I have been looking for a long time on how to set up a local sweatbox server without connecting to the actual sweatbox so I can self-train. After reading online, I found out that to create a local session on ES, I need to use the included FSD server. When I try to use it though, it keeps asking for a license. I found a license somewhere in this ES forum but it has expired and says something like "signature no longer valid" Does anyone have an updated and working license that I can use? If not, is there any other way to set up a local sweatbox with ES or with another software? Thanks in advance!
By Ashar Hussain 1374485
#528998 One more thing, I have a friend that wants to connect to my local simulation but we cannot figure out how he can join. He is using a different router and he puts my computer IP into his server on direct to vatsim. He unchecks the connect to vatsim box but when connecting, after 5 - 10 seconds, he gets disconnected.
By Ashar Hussain 1374485
#529245 I have read over that section of the wiki many times but I still cannot figure it out. I start the simulator just fine. I port forward the correct ports using my network then I give the network ip to my friend yet he is unable to join
By Ashar Hussain 1374485
#529249 Let me try and connect via another computer at my home. If it works locally then it should not be the configuation. The thing is that I have not touched anything in euroscope other then putting in a sector filing and setting up the scope.
By Sonny Nixon 1405280
#529991 Hello Ashar I shall try my best to explain the steps as I have done this previously,

  • Download Hamachi which can be found at https://www.vpn.net Both student and mentor.
  • Configure your hamachi (e.g. create an account or login, then create a network and give the network details to your "student").
  • The "mentor" should open the EuroScope FSD server and load the scenario file then when ready they should press "Start Server".
  • Once your student has joined the hamachi network, the "mentor" should open euroscope and in the connection dialogue everything should be the same as normal apart from: Select Connection Mode - Start Sweatbox Simulation, Server - "localhost", Untick "Connect to VATSIM
  • For the "student" there connection dialogue should be the same as normal apart from: Server - (mentors IpV 4 address) (http://prntscr.com/m6owz9 - have a look at that) please remember that the IpV 4 address should be the "mentors" or the person who is hosting the session, Untick "Connect to VATSIM".
  • Once the mentor has started the server and connect to the network on EuroScope then the student can do the same and if everything has been done correctly and the SweatBox file works, then you should be able to see traffic.

If you want to find out more about SweatBox servers and how to control aircraft then have a look at this guide http://www.euroscope.hu/mediawiki/index ... or_session

If you have any questions about this guide please do I ask and I will try my best to answer them :)
By Ashar Hussain 1374485
#529992 Thanks for the reply but I figured out my issue and that was because I was port forwarding incorrectly and I was able to get it to work afterwards. That guide may be able to help other though!