By Esben Emborg 1477717
#544205 Hi,

I’m newbee to X-Plan 11 with a major problem. My CH Flight Sim Yoke suddenly doesn’t work anymore. But as I see it, it’s not a problem with X-plane 11, the problem is my computer (MacBook Pro 2018, touchbar, Mojave).

I have used the CH Yoke without problems for a week now, but suddenly the OS doesn’t respond to any inputs from the Yoke. But the computer and X-plane as well, show the CH Flight Sim Yoke under system report (in Mac OS) and in my X-plane settings. But without respone.

I have already tried

On the Mac

- Rebooting
- SMC resetting
- NVRAM resetting
- Unplugging all USB devices and only plug CH Yoke
- Tried all USB ports
- Used 2 different USB-C to USB dongle’s
- Disabled OS Auto updates

On X-plane
- Complete reinstall of X-plane
- Deleted configuration files

I have managed to receive input from the Yoke (a few times) after restarting the Mac with the Yoke unplugging and re-plugging it after startup. But the Yoke only responds for a few second the it freezes completely, and I’m stuck again.

Small tip: I’m using the online tool at to test USB inputs from the Yoke. It’s faster than starting X-plan every time.


Any suggestions or hints from the community?

Are you using CH Flight Sim Yoke on X-Plane 11 without any similar problems?

By Andrew McCabe 944416
#544258 I use the CH Yoke, but on a Windows PC and FSX. However, it certainly looks like you have gone through the obvious steps to pin this down. Are you able to test the Yoke as a controller outside of Xplane, ie just as a game controller on the Mac OS ? If you can, and it works that would at least demonstrate that its not the MAC OS that's the issue and likely an Xplane issue. Also, maybe an obvious one, within Xplane is there an option to activate / deactivate controllers ? There is within FSX which is used when setting up controllers with FSUIPC. Anything similar in Xplane ?

Good luck.

By Esben Emborg 1477717
#545086 Hi Andrew,

I've added your brilliant idea in my troubleshooting, and my Yoke seems to work smoothly in Windows.

I have given up and bought the Saitek Pro Flight Yoke instead, and it works for now, so that's good. Now I'm just fighting with the usual Saitek problems like deadzones :D But I'm sure I'll get used to the new yoke.

Thank's for your response and time.

Best wishes
Esben, EKCH.