Jump to content

FSX and Win81 Power Management Joystick Disconnect issues


Recommended Posts

I have not seen a thread about this on the Vatsim forums, so I decided to start one.

 

There seem to be at least two issues that are causing USB joystick disconnects in Windows 8+.

The first one I think is related to Power Management and probably not FSX specific, where the USB joystick disappears completely at the OS level, there are several fixes for this around that are related to disabling USB controller sleep and Advanced Power Management on the joystick device itself.

The second one appears to be more complex, and is when the device disappears within FSX, even when it shows OK in Windows.

Today I was flying a 1:40h flight and about 10 minutes before landing, I tested my joke and it was responding OK. I allowed the A/C to autoland but then discovered again I was unable to taxi because it had disconnected.

 

People have reported one workaround is to unlink the joystick from FSX and use FSUIPC instead, I resist this not only because the price of FSUIPC, also because my setup is complex enough as it is, I do not want to have to tweak around just another config file.

 

There is even an app called FSX[Mod - Happy Thoughts]ist that tries to restore the joystick every 1 second, not very elegant either...

http://skypilot.biz/home/docomeents/readme.html

 

I must add that in my own experience, I was able to use this joystick on FSX on this computer for quite a long time, but WIndows 8.1 disconnects my joystick from FSX almost every flight, even after applying all the USB power management fixes I have found.

Anybody has more information about this?

Link to post
Share on other sites

I also see a joystick disconnect both in P3D and X-plane under W7.

It happens for my CH pedals, and my thrustmaster warthogs... Could in part be due to the Theustmaster Target software though...

BR

 

Stephen Slot Odgaard

VATSCA C3

 

P3D v 5: Jeehell A320, Skalarki...

MSFS w FlyByWire A320 mod, VR Reverb G2

Link to post
Share on other sites

If it is Windows 7, may (or may not) be a separate issue.

There are many threads on different fórums about changing the USB power management, so that Windows stops putting it to sleep, this is just one: (I am referring exclusively to the power management settings, I do not know about the other stuff mentioned by the poster).

http://forum.avsim.net/topic/421313-possible-solution-windows-8-and-81-joystick-solution-for-fsx-and-prepar3d/

 

UPDATE: I think that the second issue may be related to CPU overload, lowering autogen and my FPS target allowed me to make entire flights without joystick disconnects.

 

UPDATE 2: About the FSX[Mod - Happy Thoughts]ist, I am unsure if this is a permanent fix, as users are reporting in the fórum to have purchased the tool and still having issues.

 

UPDATE 3: Some FSUIPC users are also reporting the disconnects, even tho it is/was supposed to be a sure fix workaround.

Link to post
Share on other sites
  • 6 months later...
  • 2 months later...

For those using the FSUIPC workaround, I recommend also unmapping all the joystick inputs within FSX, letting FSUIPC handle them all itself. The reason for this is, simply unchecking the "Enable controller" box in FSX will also disable mouse look controls. (I'm not sure what it does to TrackIR or EZDok, having never owned either product.)

2uo1990.png

 

You don't need Red Bull to get your wings.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...