Jump to content

ASE Crashes When Trying to Load Sector File


Recommended Posts

I just got a new PC. It happens to have Windows 8.1. Now, while that may quickly set you off, please understand my problem. I've been able to get VRC, ES, Squawkbox, FS, TS and various other programs working fine. My problem is ASE. When I bring it up, if I try to load a sector file I get a message saying a problem has occured and the program must close. I've tried multiple sector files and it does the same thing. I don't understand why this particular task has created a problem because these same sector files load just fine in VRC.

 

Any help?

Link to comment
Share on other sites

Where did you install the ASE program? If the program is very old, it might work better if it were installed out of the normal program files hierarchy. For example, into your Docomeents folder. This is of course, a security risk (Windows no longer prevents the program from changing files in its install location. Since writing situation files might be considered the reason for being for ASE... ) If you trust the program, you might try this.

 

It is possible that the attempts by Microsoft to coddle programs that disobey the now-ancient guidelines such as writing output files to non-sensitive locations have failed in this case. So installing it to a place that is not protected might remove that potential issue.

 

 

On another topic, .sct and .sct2 writers have over the years developed ingenious ways to stretch far beyond the allowed formatting specified for .sct and .sct2 files. I have several sector files (with obvious out-of-spec lines) that VRC will open and ASE won't. VRC apparently uses Advanced Alien Technology to guess the meaning of some of the out-of-spec shortcuts users have developed over the years. I got tired of trying to outguess the users in sector file manipulation software I've written for myself, and in those cases that were too annoying, I've just fixed the sector file to better match the spec.

Link to comment
Share on other sites

I think I've realized ASE will load any sector file that has next to nothing in it. Or, it will load my vZAU sector file as long as I have everything turned off (which of course means I can't see anything on the screen). Once I try to turn anything on, it stops working.

 

Now that I've installed FS9, this happens with add-on aircraft too. I cannot get an add-on aircraft to work as it gives me the same "A problem has caused this program to stop working" and it closes out. Super frustrating.

Link to comment
Share on other sites

Hi Mathew,

 

Do the sector files you are trying to load work on another machine? Would you be able to send me the sector file so I could have a look?

 

Check your Event Viewer on your machine, it might give some clues to why it is crashing out.

 

Regards

 

Craig

Craig Phillips

 

Senior Student - UK South East - Mentor

Developer: Aircraft Situation Editor (ASE)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...