Jump to content

Recommended Posts

Winsock Error (10060)

 

I've been using TWRTrainer without problem for few years as training manager of VATJPN.(windows 7, 64bit, SP1)

But tonight, when I open the *.air file, winsock 10060 error occurred.

Another member of my team tried to open the *.air file, it gave the same error.

(We can connect to the sweatbox using VRC.)

 

TWRTrainer throws this error :

"The following winsock error occurred with index 0:

(10060) The attempt to connect timed out"

 

Followings are what I have tried (but doesnt work).

1 : checked my CID and p[Mod - Happy Thoughts]word

2 : connecting server -> sweatbox.vatsim.net

3 : off the antivirus software and firewall

4 : tried ACSIM, but was not able to load a file

5 : reboot my computer and router

6 : run as an administrator

 

Also I have read similar topic "Winsock Error (10061)".

viewtopic.php?f=50&t=43444

viewtopic.php?f=50&t=57997

 

Anyone have ideas?

 

---------------

Masaki Hasuike

VATJPN2

Masaki Hasuike / 1141450 / VATJPN1

banner60.png

Link to post
Share on other sites

That's interesting. Version 1.0.97, yes?

 

I just tried a couple of times, and 0 aircraft were able to successfully connect.

 

EDIT: Also verified using Wireshark that TWRTrainer is receiving 0 packets from the server when it attempts to connect.

 

EDIT2: And now the server is forcefully refusing VRC connections (SYN packets are met with RST+ACK immediately).

Edited by Guest
Link to post
Share on other sites

No, I'm using a later version that is not available ... I'm not sure what the differences are and there's no way for me to find out. I wrote this code 6+ years ago and don't even have the VB6 development environment set up any more.

 

Kieran, what changed recently on the SB server?

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
Try pinging the server from your machine. See if you can reach it.

 

tried pinging "sweatbox.vatsim.net" and "www.vatsim.net"

 

this is the result.

------------

Pinging sweatbox.vatsim.net [95.85.51.216] with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

 

Ping statistics for 95.85.51.216:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

 

Pinging http://www.vatsim.net [176.9.27.196] with 32 bytes of data:

Reply from 176.9.27.196: bytes=32 time=260ms TTL=44

Reply from 176.9.27.196: bytes=32 time=263ms TTL=44

Reply from 176.9.27.196: bytes=32 time=270ms TTL=44

Reply from 176.9.27.196: bytes=32 time=260ms TTL=44

 

Ping statistics for 176.9.27.196:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 260ms, Maximum = 270ms, Average = 263ms

------------

 

Is this a problem with the server side?

 

And my TWRTrainer is version "1.0.101".

 

 

---------------

Masaki Hasuike

VATJPN2

Masaki Hasuike / 1141450 / VATJPN1

banner60.png

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...