Jump to content

Joystick disappears from system completely whilst online!


Lorenzo Francois
 Share

Recommended Posts

Hello everyone,

 

Looking for some advice on a little problem that I have encountered flying online and most inconvenient!

 

System is:

 

MSI i7 4700HQ 2.4 Ghz Gaming Laptop

8Gb Ram

Nvidia Gforce GTX860M 2Gb

1TB HHD

Secondary monitor.

Logitech extreme 3d pro joystick.

 

Windows 8.1 64bit

FSX SP1/2

Latest version FSPIUC (unregistered)

Vpilot

Active Sky Next

Vroute

 

Payware Addon aircraft

QW 757-200

Airbus X Extreme

Carenado B1900D and CT206H

 

Problem:

 

Whilst flying online and interacting with the exterior programs such as vroute, to see other aircraft and controllers, Vpilot (using chat function on UNICOM), the joystick tends to just disappear from the system all together. Most inconvenient as it usually happens on approach and I have to subsequently log off so as no to cause any problems for others. I run the simulator on the secondary screen and the other applications on the laptop screen, I do understand that vpilot is an exterior program to FSX and the sound cuts out, however are there any other conflicts that may arise due to constant exterior interaction? It was further suggested to uncheck the power saving options on all the USB connections as windows 8 tends to turn them off, thats done! Still encountered the problem, could it be an issue with the joystick itself as the mouse still stays connected and usable?

 

Can anyone help as I have not seen this problem occur on the forums. If other information is needed please let me know, mind you i am not as proficient in computer programming/tweaking so please be patient with me.

 

Many thanks

 

Lorenzo (AFA3985)

Link to comment
Share on other sites

Yep, you can get a positive report from me, too.

 

With FSUIPC 4.934 and Win 8.1 64bit (Genuine and updated for those who wonder), the joystick is completely lost from FSX (not the system!) and that could happen anytime I mess around with another window, from my observations. Actually the first time it happened, I was on Gatwick approach making me to GA and try to find a way to fix this.

 

The only feasible way to make FSX see my joystick again, was by completely disconnecting vpilot, exiting the app and finally reopening it. When the app is started, joystick comes back alive until something makes it again to lose it.

 

It might be the pushbutton for voice [Mod - Happy Thoughts]igned to my joystick, causing things to be messed up but I'm not able to put the blame on that for now.

Alex (OAL554)

Link to comment
Share on other sites

This is an incurable disease in the windows 8/8.1. FSUIPC? More sufficient USB power supply? anyone doesn't prevent disappearing.

 

Just need to stay FSX.EXE to main focus.

 

Next is my solution.->

 

If loss joystick, Press Ctrl+Alt+Delete, and Press Esc to recover FSX. then sometime recovered joystick.

1285012.png
Link to comment
Share on other sites

Not sure if this is relevant to your case(s), but ever once in a while FSX seems to "forget" about my yoke, too. I have it mapped through FSUIPC, and what cures it every time it occurs is to open the FSUIPC window from the FSX menu and just close it immediately afterwards. If clicking with one hand and pressing ESC with the other to close it is merely a matter of one second, and I doubt anyone will ever notice anything.

 

Might be worth giving a shot.

 

Regards

Oliver

Link to comment
Share on other sites

  • 1 month later...

I've run into this too, and for me, the easiest way to get the joystick back is simply to press "ALT+ENTER" to go to/from windowed mode to Full screen, or Full Screen back to windowed mode. Works 100% of the time, though there are times when it takes a couple of such button presses to revive the joystick.

Fly Safe! Have Fun!

Craig Moulton

 

810358.png

Link to comment
Share on other sites

The combination of fixing the USB power settings and Don't Lose Your Stick worked for me. I used to lose the joystick within seconds of clicking outside of the FSX window. For me this only happened with CPU intensive aircraft, not the defaults, but it happened every flight. Now I can't lose the joystick no matter what I do.

 

I have the joystick disabled in FSX. I have flight controls mapped through DLYS and view controls mapped via EZCA.

 

If the joystick is lost from DLYS, you should be able to restart DLYS to get it back without restarting FSX.

Link to comment
Share on other sites

  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...