Jump to content

Mode C not working


Gregg Seipp
 Share

Recommended Posts

I was flying on VATSIM today and Mode C on vPilot wouldn't engage. The transponder on my aircraft (Flight1 Mustang) was on and squawking alt. I'd click Mode C and it would flash and go back dark. The controller said he saw it briefly. Tried restarting vPilot...did not help. Any ideas?

 

Gregg

 

EDIT: I set 'Squawk automatically on takeoff', restarted the sim and vPilot and this time Mode C was set and wouldn't turn off. I unchecked the automatic squawk and it still wouldn't turn off. I then switched from the Mustang to the A2A C172 and the button worked fine. Worked fine with the Turbine Duke as well. Went back to the Mustang and it wouldn't work again. So...it appears to be a problem with the Mustang.

Link to comment
Share on other sites

This is a known issue - it's a problem with the way Flight1 reports the state of the transponder. See this thread on the vPilot forums for the full story.

 

EDIT: Note that the issue is that the transponder state is inverted. Thus, just set the G1000 to "GND" when you want to squawk normal, and "ALT" for standby.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...