Jump to content

vPilot voice problem


Dhagash Kapadia
 Share

Recommended Posts

Hi, I quite recently got a new microphone. It so happens that when I try to transmit through vPilot, the transmission button gets highlighted, but the controller doesn't receive my voice. On his side, he has the receiving icon highlighted, but he can't hear me. Except vPilot, my mic works perfectly in other softwares like TeamSpeak, etc. I tried reinstalling vPilot as well as reinstalling windows, but that didn't help. Earlier it used to work fine with my inbuilt webcam + mic. Ever since I moved to a new one, it doesn't work. Any help would be appreciated.

Link to comment
Share on other sites

  • Board of Governors

Try switching your device mode (Wave vs. Directsound).

 

Also, and it's happened before to others (and me, by the way!) as a simple oversight, so no insults meant, but verify that the audio device (headset) you're trying to use is truly the one that is selected in vPilot. I think that that when I have switched headsets before, or sometimes plugged in my headset after starting vPilot, I had to go in and ensure the correct device was selected.

Don Desfosse
Vice President, Operations

Link to comment
Share on other sites

Um........well, this one doesn't need an external installer for a driver.

 

That just means the driver is included with Windows.

 

Is this an only vPilot and Euroscope problem? Or it may occur with SquawkBox or FSInn too?

 

You're the only one that can answer that.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

  • Board of Governors

I can't remember, and I'm sure Ross or someone will chime in, whether if the UDP 3290 port were blocked, if the PTT keypress would indicate a transmission and just not allow the voice, or if there would be no PTT indication.

 

Here are a few thoughts, in descending order of likelihood of helping (you can tell I'm really grasping at straws after the first couple):

 

The first two steps are covered in the vPilot Tips, Tricks, FAQ and Troubleshooting Guide

1. Please verify that UDP port 3290 is forwarded on your router.

 

2. Another possible cause is that your antivirus/firewall is blocking the UDP port. You will need to either close conflicting applications and/or ensure your antivirus/firewall will accommodate any of the pilot clients. You can test this by temporarily disabling your antivirus and firewall, starting vPilot, do a transmission test, and seeing if that solves the issue.

 

3. One other thought, since you mentioned FSInn, ensure the FSFDT control panel (which handles voice for FSINN) is not set to autostart. If it is, it will take control of the UDP port, not allowing other programs access. The flaws in that thought is that FSInn should work, and vPilot mic calibration should work.

 

4. If you have access to another headset, even one that you could borrow to test, plug that in and then try again and see if you can isolate to how the headset is interacting with the programs.

 

5. I know this last one is a long shot (which is why I listed it last ) since you said your microphone was working with other audio applications, but this issue could also appear if your computer isn't recognizing your input sound device is installed (or configured as active). With vPilot running, on Windows, right click on the speaker symbol, then select Recording devices. Tap on your microphone or make a sound. Do you see the green bars move up ?

Don Desfosse
Vice President, Operations

Link to comment
Share on other sites

Ernesto I just saw your post And yes, before starting vPilot I have checked all other voice clients are shut down. And Don - for now I use a headset only for speakers, and a desktop mic for my use (yes, those green bars move accordingly even if there's a slight noise out here somewhere). And I've been trying to post here since long, but my net would eventually screw up and disconnect me from browsing -_- Well, I've got an update, somehow I resetted my router to factory settings and when I transmitted, the controller said he could hear static noise, but no voice. So does this mean I'm a bit close to my solution?

Link to comment
Share on other sites

Ok, these are the port forwarding rules for my WiFi router. http://prntscr.com/642u48

I've got to get this mic working anyhow before 14th as I have my OTS then. I've tried almost everything you wrote Don, except the 4th one. The green bars in windows move up, and it works properly 5/5 with all other applications except VATSIM clients. This was my voice calibration in Euroscope after port forwarding - http://prntscr.com/642v81

Link to comment
Share on other sites

  • Board of Governors

Short of obtaining a USB headset (either borrow for troubleshooting or purchase), which has an integrated sound card (so you'll need to remember to select your headset in your program), if you have already verified that you have selected the correct input device (e.g. under Primary Input Hardware), I'm out of ideas. Good luck.

Don Desfosse
Vice President, Operations

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...