Jump to content

X-Plane Framerates and flying on VATSIM (with XSB)


Recommended Posts

Hi All,

 

I've had some interesting discussions lately and I'd like to bring some awareness to an issue which most of you are probably unaware of.

 

When flying on VATSIM, (at this time) it is somewhat essential that you ensure X-Plane is capable of sustaining a minimum frame-rate of 20fps or higher.

 

This is because X-Plane will warp simulation time for frame-rates below 20-fps to ensure that the simulation continues to work reasonably well.

 

This results in you flying an effective true air speed slower than what the client is reporting, causing trouble with ATS separation, both with establishing your actual GS and issuing speeds that will separate you appropriately.

 

It's also worth noting that it's entirely possible for low frame-rates to negatively affect other aspects of XSB too, so it's well worth aiming for a higher frame-rate if possible.

 

FSX and P3D do not have this issue with low frame-rates as their simulations are relatively tolerant to long simulation update intervals, and simply drop updates in these circomestances, rather than slowing simulation time.

 

Going forward, new releases of XSB will start monitoring simulation time to detect rate slips so it can warn you if you're experiencing this problem. Other changes may also be made to minimise the impact of this issue upon ATS. I don't have a set time-frame for these changes yet, but they will most likely feature in the next release of XSB.

 

Until these changes are made, please follow the process offered by Laminar to verify your actual frame-rate, and adjust it to bring it up to a minimum of 20fps.

XSquawkBox - Developer/Maintainer

 

Please post any support related questions to the XSquawkBox support forum rather than private messaging me, thanks.

Link to post
Share on other sites

Thanks for the insight Chris. I have a symptom that seems similar to what you described. During my start up procedures when I connect XSB to the network the frame rate/simulator starts to lag. I have discovered that if I disable XSB through the Enable/Disable plugins menu and then enable and reconnect everything moves along swimmingly.

Andrew Morkunas

Twitch: padre_andrew ATC Simulations

 

0

Link to post
Share on other sites
  • 2 years later...

I figured, the one responsible for dropping fps is actually not the settings much less the hardware.The problem is actually in the network manager which in this case is xsquawkbox. My machine can keep 50 fps quiet. Just activate the xsquawkbox at the airport, they drop to up to 12 fps, thus making the simulation not real.Soon after the takeoff the simulator returns to normal, we need to urgently find a solution for this, because I loved the network but this is making difficult too, in the final app will disrupt the other traffic that can keep fps in the 20's because it has a greater potential that's my hardware.I have already tested in another network and it worked normal I did not have this type of problem, if someone has contact or can be responsible for the plugin please look for the same to solve this, as well as harm to force the components of the machine and, this does not make a healthy simulation to them.

Link to post
Share on other sites

Hi Marcelo,

 

this sounds like a problem with your multiplayer aircraft that XP is displaying. Make sure that XSB has some light CSL installed, e.g. BlueBell. I am flying with XP11.26 and XSB and I do not have this issue.

Link to post
Share on other sites

Rather than use the AutoSpeed plugin, a better option would be to install something like the 3jfps-wizard Lua script: https://forums.x-plane.org/index.php?/files/file/43281-3jfps-wizard11/

 

This script will automatically adjust your rendering options on the fly to maintain a set minimum framerate.

Dhruv Kalra

VATUSA ZMP ATM | Instructor | VATSIM Network Supervisor

878508.png878508.png

Link to post
Share on other sites
  • Board of Governors
A possible theoretical fix I've been thinking about for this, is just to give the plane a higher speed restriction to compensate, don't you agree?

The problem is when the pilot believes he's flying at 200 knots, but ATC "sees" him flying at a rate that is roughly 1/5 of normal. Very hard to [Mod - Happy Thoughts]ign a pilot to fly at 1,000 knots...

Don Desfosse
Vice President, Membership

Link to post
Share on other sites
  • 1 year later...

hi, is there any difference about this stuff between versions 1.3.3 and the new beta version (2.0beta3)?

 

With the 1.3.3 version I never, ever saw the message warning about the automatically disconnect if the frame rate was below 20.

 

With the beta, and after put the same settings on the plugin, I always see this warning and sometimes the plugin remove me from the network.

 

I do not have changed anything related with the graph settings.

 

My X-Plane is 10.50 version under macOS 10.13.2.

Félix Zapata (1245159)

Events manager / Responsable de eventos (ACCSP4)

Deputy Director / Director Adjunto (ACCSP2)

VATSIM Spain (a.k.a VATSPA)

Imagen

UAL682.png

Link to post
Share on other sites
hi, is there any difference about this stuff between versions 1.3.3 and the new beta version (2.0beta3)?

 

With the 1.3.3 version I never, ever saw the message warning about the automatically disconnect if the frame rate was below 20.

 

With the beta, and after put the same settings on the plugin, I always see this warning and sometimes the plugin remove me from the network.

 

I do not have changed anything related with the graph settings.

 

My X-Plane is 10.50 version under macOS 10.13.2.

If you’re being disconnected, it means your simulator isn’t maintaining 20 FPS minimum as well as real-time simulator rate.

Dhruv Kalra

VATUSA ZMP ATM | Instructor | VATSIM Network Supervisor

878508.png878508.png

Link to post
Share on other sites

yes, i know but why does it happen with the beta version. I've been using the 1.3.3 version since it was released and I never had this problem and I never saw this message.

 

so, is this rate checking new with the beta?

Félix Zapata (1245159)

Events manager / Responsable de eventos (ACCSP4)

Deputy Director / Director Adjunto (ACCSP2)

VATSIM Spain (a.k.a VATSPA)

Imagen

UAL682.png

Link to post
Share on other sites

Correct.

 

Slow-motion X-Plane users are increasingly present on the network as X-Plane’s popularity has increased. The rate checking is a measure to attempt to educate the user base as well as minimize their adverse impact on ATC during busy events.

 

The end goal is that you adjust your graphics settings in X-Plane to maintain the minimum frame rate at all times on your hardware.

Dhruv Kalra

VATUSA ZMP ATM | Instructor | VATSIM Network Supervisor

878508.png878508.png

Link to post
Share on other sites
  • 1 month later...

Same here, I have 25-26 rate but it keeps disconnecting me, it seems really unfair. Even with lowering my settings I get disconnections. I have to say these disconnections don't help with traffic and defeats the whole purpose of this new rule.

Link to post
Share on other sites
  • 2 months later...
Same here. i`m around 30 fps sometimes 25 but never under 20fps and get message all the time.

The problem is not with XSB. The plugin is doing what it is designed to do. I was getting warnings as well, but never any disconnects. And, was getting 45-60 FPS when I would get the warning. I logged a data file and went for a flight on the network, which I received a warning about an hour into the flight. After the flight I reviewed my data file and found that my frame rate was going from 49 to 19 for a few seconds and then it would recover. Hence never a disconnect.

 

My problem was caused by a wireless headset that would hit my CPU every hour or so for whatever reason. Changed to a wired headset and problem was solved.

 

You may think you are getting good frame rates when in reality you are dropping them. And it's not always the GPU. It's actually the milliseconds of lag that is permitted before warnings and finally disconnect. I think it's 50ms max lag.

 

Cheers,

Steve B.

Link to post
Share on other sites
  • 4 months later...

Today I flew on VATSIM from EHAM to LFPG. Coming in to LFPG my frame rate went down to 8 which is unusual. While at altitude, my frame rate was around 35 to 45, only when on FINAL to Rwy 26L in LFPG did my numbers go down to 8. Obviously I got disconnected.

There were center, approach and tower controllers on duty and there was quite a bit of traffic and action around the airport. Could this be the cause of this slowdown in my frame rate? 

Could the fact that Vatsim was working on incorporating MSFS 2020 into the system the cause?

I'm on a Mac flying XPlane 11.41 using the Zibo 737/800x version 3.43

I've had my frame rate go down low sometimes at high altitude. It usually stays low for a few minutes and suddenly goes back up to 35 to 45.

What are the possible causes of these sudden losses in frame rate?

Any words of advice would be appreciated. 

Edited by Michael Eamer
typos
Link to post
Share on other sites
  • Board of Governors

The more traffic online that has to be rendered, coupled with weather and scenery can easily overwhelm your system during busy events. So that is likely what caused it. Incorporating Microsoft Flight Simulator would have nothing to do with your local frame rates.

Matt Bartels
VP: Marketing & Communication
## vpmkt (at) vatsim.net
Facebook Twitter Instagram
VATSIM Logo

Unless otherwise stated, opinions are my own and not representative of the official opinion of the VATSIM Board of Governors

 

 

 

Link to post
Share on other sites

Although normally displaying traffic should not impact your frame rates too much, at least in X-Plane. From tests we took away that there MAY be a short "stutter" when traffic gets injected into your SIM, but as soon it is there, the impact on frame rates is minor to nil.

I had tested this last year during a CrossThePond event in KJFK on the ground with more than 60 aircraft displayed: I had a loss of 1 to 2 FPS, that's all.

Have you tried activating Vulkan/Metal? Your FPS should go up quite a lot.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...