Jump to content

Vpilot "Version check failed" error


Recommended Posts

I run P3D v3.3.5 on my networked PC simulator based on four client computers for outside scenery view and one server computer for controlling client computers and also for display of virtual cockpit panel. To join vatsim, I have installed Vpilot on server and all client computers. When I run vpilot on client computers, it runs successfully on all the client computers. However, on running Vpilot on server computer, I get following error message :

 

[09:52:37] Version check failed: The service cannot be started , either because it is disabled or because it has no enabled devices [Mod - Happy Thoughts]ociated with it. ( Exception from HRESULT: 0X80070422)

[09:52:41] Network server list downloaded. 17 servers found.

 

If I press "Settings" Tab, thenan other window opens with "vPilot" title with following error message :

Unhandled exception has occured in your application. If you click Continue, the application will ignore this error and attempt to continue. if you click Quit, the application will close immediately. Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

 

When I click "Continue" tab, the window closes and I return back to main window of vPilot.

All this happens only when I click "Settings" tab and so I can not make any changes in default settings of vPilot. If I press"Flight Plan" tab on left side of "Settings" tab, "File Flight Plan" window opens successfully and I am able to make changes in Fligt Plan parameters.

 

It is to be mentioned that Simconnect version installed on server and client computers is same i.e. 10.0.61259.0.

But strangely, this error message is appearing only on Server computer.

 

Help regarding this issue is requested please.

Link to post
Share on other sites

I finally solved the above mentioned issue.However, now I am facing problem such that vPilot is continually "Attempting simulator connetcion" and in return error message is appearing as "Simulator connection failed."

 

I am not sure but may be it is relevant to incorrect setting of SimConnect.cfg or SimConnect.xml files.

If anyone can figure this out that would be very helpful. Moreover, any link regarding correct setting of SimConnect.cfg and SimConnect.xml files would be of great help.

Link to post
Share on other sites

Hello Faisal,

 

I suggest you uninstall vPilot version 1 and install vPilot version 2.0, which is currently available for anyone to beta test. It has been running stable for quite a while now and I will be ending the beta and releasing it as stable soon.

 

You can download it here: viewtopic.php?f=132&t=70966

 

vPilot 2.0 runs directly on the machine that is running P3D and therefore you don't have to use SimConnect networking configuration files. You can still run the vPilot user interface on a remote machine (such as your server) if you want, by running it in "host" mode on the client sim machine, and in "remote" mode on the server.

 

However, vPilot cannot run on more than one client sim machine at the same time, so it may not work for your setup if you have more than one copy of P3D running. This is because each copy of vPilot makes a connection to VATSIM, and you are only allowed to have a single connection to VATSIM.

 

So you will have to run vPilot on one of your sim machines, and use some other software to copy the aircraft to the other sim machines, such as WideTraffic. I've never tried using WideTraffic so I don't know how well it works.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...