Jump to content
Ray Lang

FSUIPC - Widecilent - VPilot Version 2

Recommended Posts

Before I did the upgrade from VPilot V1.x to V2.x i manage to get one of my buttons on the yoke to trigger a function key F12 for communications to ATC.

Vpilot V1.x was installed on the non P3D computer with wide cilent installed. I have setup FSUIPC on the P3D computer via a keysend command to Wide cilent to trigger the function key F12 which triggers the transmit button to communicate to ATC.

 

Since installing VPilot V2.x this no longer works. I have VPilot Host no voice on the P3D computer and Vpilot remote with voice on the non P3D computer.

 

The two computers are networked.


Ray Lang

Deputy Regional Director - VATSIM Oceania

Vatsim Senior Supervisor

Team Lead 1

Pacific Oceanic Partnership Admin

Have a question? Email [email protected]

u559tvN.png

Share this post


Link to post
Share on other sites

Ross Vpilot host on the P3D computer does recongise the yoke. Vpilot host doesn't handle voice communications VPilot remote on the non P3D computer handle the voice communications. I was trying to have the yoke button which is on the P3D computer to be recongise by VPilot remote on the non P3D computer but no luck.

I have try it on VPilot host which recongise the yoke button but will not trigger on VPilot remote voice. The only way i can get it to work is thru fsuipc keysend command to wide cilent in turns triggers the ptt on vpilot remote.


Ray Lang

Deputy Regional Director - VATSIM Oceania

Vatsim Senior Supervisor

Team Lead 1

Pacific Oceanic Partnership Admin

Have a question? Email [email protected]

u559tvN.png

Share this post


Link to post
Share on other sites

The host should be sending the PTT press/release events to the remote, so that it can begin/end voice transmission. Could you open the debug window on both the host and the remote and toggle PTT a few times and see what you get in the debug messages on both machines? You should see messages on both showing the PTT toggling on/off.


Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

20.png

Share this post


Link to post
Share on other sites

Hi Ross.

 

I have the same problem. I have up-graded from V-Pilot V1 to V2. I use the PTT button on the yoke which is connected to the host (FS) PC with the main Viplot window and sound running on athe remote PC. It was working in V1.

 

In the new V2:-

I have set the Host PC to run as "vPilot Host Mode".

I have set the Remote PC to run as "vPilot Remote Mode with Voice"

 

The system seems to connect perfectly- vPilot on the Host PC connects with P3D, vPilot on the remote PC connects with the Host PC and P3D and the su=ystem connects to Vatsim on line.

 

When I was using vPilot V1, I had set the PTT buton on the yoke set and this setting has carried through to the newly installed V2. It is not recognised on the remote PC however. I have tried to configure it in the settings on the Remote PC but it is not recognised.

 

I am not sure I understand the solution that has been mentioned and I would be grateful for any advice.

 

Thanks to all the team for the work on this great program. Having been a long time member of Vatsim I really appreciate the improvements that have been made... Keep Going!

 

Michael

Share this post


Link to post
Share on other sites

Make sure you set the PTT on the Host Vpilot and not on Vpilot Remote Voice leave that blank. If you are running FSUIPC and Wide Cilent and using keysend commands remove them from FSUIPC.ini an Widecilent.ini that triggers the PTT for VPilot.

 

Still no go I would checkout P3D settings within the game to make sure you don't have a conflict with the key you are using for VPilot.

 

One way of testing the PTT by changing your radio to 122.8. Trigger the PTT if you hear a sound each time you press it you know it working.


Ray Lang

Deputy Regional Director - VATSIM Oceania

Vatsim Senior Supervisor

Team Lead 1

Pacific Oceanic Partnership Admin

Have a question? Email [email protected]

u559tvN.png

Share this post


Link to post
Share on other sites

Ross,

 

The problem is solved! I followed your advice in relation to how to properly activate the PTT button on the Host PC and make sure that it was not activated on the Remote PC. It worked after that. I think that I was trying to do it the other way around originally and that was the problem. Apologies for my ineptitude!

 

Perhaps it might be worthwhile to emphasise this in the next issue of the guidance manual. I wonder also if this thread should be titled "PTT Problem" rather than it's current title which appears to have little to do with the actual subject matter.

 

I am really grateful to you for your help. Keep up the good work!

Kind Regards,

Michael

Share this post


Link to post
Share on other sites

Ross with vpilot remote voice been on the non P3D computer I have try to set the PTT button by the yoke which is plug into the P3D computer and vpilot remote doesn't pick it up. I have setup the yoke button on the Host non voice on the P3D computer which VPilot Host picksup and triggers the PTT on the VPilot remote voice on the non P3D computer. It works I'm happy.


Ray Lang

Deputy Regional Director - VATSIM Oceania

Vatsim Senior Supervisor

Team Lead 1

Pacific Oceanic Partnership Admin

Have a question? Email [email protected]

u559tvN.png

Share this post


Link to post
Share on other sites
Hmmmm ... not sure exactly what you're saying the fix was. Can you elaborate?

 

You can certainly have a PTT key/button set on both the host and the remote, that shouldn't cause any issues.

 

Ross, Now I am not sure what the problem was, but it seems most likely that I had the wrong modes selected for the Host and Remote PCs. Whatever it was, it appears to have been my fault because it is now working perfectly and I have not altered any of the software or hardware. The software was clearly not the problem.

Sorry I cant be more specific... Many thanks for your help.

 

PS, I completed a flight this evening on Vatsim from Manchester to Amsterdam and it was flawless!

 

 

Michael

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...