Jump to content

Recommended Posts

Gergely, could you elaborate on what the role of MSVCR100.dll is in ES r12, and if you know of any possible reasons for it to cause a CTD during the data loading resulting from activating Primary? Because that's what my r12 version has been doing ever since it first was released. My 3.2 vanilla works 100% of the time, no CTDs what so ever. The r12 version crashes 19 out of 20 times at the end of the Primary freq data gathering. The lists fill, active neighbouring sectors are drawn, but just as all the lists are done with the initial gathering, the crash report below appears. This happens with or without audio hardware connected, in any install scenario (overwrite or parallell to 3.2), in any compability mode or admin mode, DPI settings, etc. It happens in Win Safe Mode, it happens running the pure win7 Admin user, it has happened after any and all windows update since the r12 release. I've completely removed all the C++ visual redist packages, not only the ones ES uses, and installed all of them in sequence with admin rights. I've tried making the .dll's read only, I've basically tinkered with any property setting of any module or exe, blanking certain ES data files, and lots more. The only thing I have not tried is formatting.


It's also my understanding that the same module appears to be faulty when others in my vACC experiences CTDs with r12, though they usually have one crash per 50 logins, and they're typically linked to the ATIS or VCCS. I've not encountered anyone who experiences it during activation of Prim. I don't know wether this is something that narrows it down or not.


If ES makes it past the first 5-10 seconds after activating primary, nothing takes it down. It runs until I do a restart or toggle the Primary frequency. Other software running has, as far as I can tell, no impact on the chance of success during initialization. Thoughts?


Problem signature:
 Problem Event Name:	BEX
 Application Name:	EuroScope.exe
 Application Version:
 Application Timestamp:	57a77fb9
 Fault Module Name:	MSVCR100.dll
 Fault Module Version:	10.0.40219.325
 Fault Module Timestamp:	4df2be1e
 Exception Offset:	0008af3e
 Exception Code:	c0000417
 Exception Data:	00000000
 OS Version:	6.1.7601.
 Locale ID:	1044
 Additional Information 1:	3d0f
 Additional Information 2:	3d0f327694db07bf55c905e252be7d86
 Additional Information 3:	f5ba
 Additional Information 4:	f5baa8f6eab27ad962addf7e337d7dc7

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:

Link to post
Share on other sites

As an update, I've formatted my OS drive and installed a new OS from a different source, and only installed the bare minimums of software that I need. I've not used any old/previous files in the new installation of ESr12, only files downloaded from the ES site and my vACC. Still the CTD's at Prim Set occurs. I've also recently changed my graphics card, and the problem's been persistent both before and after. This is getting interesting.

Link to post
Share on other sites
  • 4 months later...

I'd like to add that this issue seems to be gone now for all beta versions, I believe the reason is I went ahead and ensured that my WIN user had full ownership of all system folders, using the registry trick to add "Take Ownership" to the right click context menu (google this, guides for both win7 and win10, but as with everything in OS setup, be very carefull and take backups).

Link to post
Share on other sites

Well, yes, but it hasn't been only one issue for me. I've had trouble with vcredist for a year or so (now all gone). And you can't mess up too horribly with folder ownership settings, really. But backup is mandatory for going down that path regardless.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...