Jump to content
Roger Curtiss

CH Pro Pedals and TQ not being Recognized

Recommended Posts

Yesterday my Pro Pedals and TQ were working just fine running through a Belkin USB hub as they have for a few years. Today I installed a second monitor and in sorting out the cables I did unplug the hub. After plugging back in I found that the Pedals and TQ are no longer being recognized as being connected. I am also using a joystick (my CH Yoke recently stopped functioning properly after years of service) and the hub recognizes the stick. I also tried plugging the joystick, pedals and TQ directly to USB ports on the computer and again, the stick was recognized but not the CH products. I have tried numerous times plugging and re-plugging into various ports and combinations and restarting the computer (Windows 10) and I am out of ideas.


Roger Curtiss

VATGOV9

VP-Virtual Airlines & Special Ops

r.curtiss(at)vatsim.net

 

810159.png810159.png

Share this post


Link to post
Share on other sites

I don't know if you fixed your problem, but I had similar strange issues and ran a usb cleaner then plugged things in one at a time.

 

I don't remember which software I used, but it helped start over.


Scott Bickford

810789.png

810789.png

Share this post


Link to post
Share on other sites

Well, the good news the hardware started working again. Bad news is I have no idea why.


Roger Curtiss

VATGOV9

VP-Virtual Airlines & Special Ops

r.curtiss(at)vatsim.net

 

810159.png810159.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...