Jump to content

Connection timed out


Recommended Posts

Hello guys ,

 

Im facing with problem regarding the SSO in IP.Board forum and wordpress website.

The error occured at the same time in both platforms so im not sure what is going on ....

 

" An error occurred

Error code: 28

Error message: connect() timed out! "

 

Any suggestions ?

 

Thank you very much !

Link to post
Share on other sites
Hello guys ,

 

Im facing with problem regarding the SSO in IP.Board forum and wordpress website.

The error occured at the same time in both platforms so im not sure what is going on ....

 

" An error occurred

Error code: 28

Error message: connect() timed out! "

 

Any suggestions ?

 

Thank you very much !

 

The demonstration SSO environment is currently inoperable, see this mini-PSA from VP Web.

 

connect() isn't a function that seems to be used anywhere in the IPBoard SSO, could you elaborate a little more?

 

If you're currently using IPB4.3.3 or above, you might need to update to this version of the authentication handler.

Kind Regards,

Kieran Cross,

 

28.png

Link to post
Share on other sites
Hello guys ,

 

Im facing with problem regarding the SSO in IP.Board forum and wordpress website.

The error occured at the same time in both platforms so im not sure what is going on ....

 

" An error occurred

Error code: 28

Error message: connect() timed out! "

 

Any suggestions ?

 

Thank you very much !

 

The demonstration SSO environment is currently inoperable, see this mini-PSA from VP Web.

 

connect() isn't a function that seems to be used anywhere in the IPBoard SSO, could you elaborate a little more?

 

If you're currently using IPB4.3.3 or above, you might need to update to this version of the authentication handler.

 

Hi Kieran ,

Thank you for replying

Maybe im worng and we are talking about two different failures but i will try to be more specific :

 

1. In wordpress site i get the error i wrote above ("connect() timed out!) , i used BlaatSchaap SSO: VATSIM plugin,

it was working until yesterday morning - there is any connection to the demonstration SSO environment?

 

2. Regarding IPB forum - the version now is 4.3.2 (we havne not upgrade yet) and its was working too until yesterday morning. The error there is just "Something went wrong. please try again"

Link to post
Share on other sites
Hello guys ,

 

Im facing with problem regarding the SSO in IP.Board forum and wordpress website.

The error occured at the same time in both platforms so im not sure what is going on ....

 

" An error occurred

Error code: 28

Error message: connect() timed out! "

 

Any suggestions ?

 

Thank you very much !

 

The demonstration SSO environment is currently inoperable, see this mini-PSA from VP Web.

 

connect() isn't a function that seems to be used anywhere in the IPBoard SSO, could you elaborate a little more?

 

If you're currently using IPB4.3.3 or above, you might need to update to this version of the authentication handler.

 

Hi Kieran ,

Thank you for replying

Maybe im worng and we are talking about two different failures but i will try to be more specific :

 

1. In wordpress site i get the error i wrote above ("connect() timed out!) , i used BlaatSchaap SSO: VATSIM plugin,

it was working until yesterday morning - there is any connection to the demonstration SSO environment?

 

2. Regarding IPB forum - the version now is 4.3.2 (we havne not upgrade yet) and its was working too until yesterday morning. The error there is just "Something went wrong. please try again"

 

Just to clarify, are you using http://sso.hardern.net/server/ or https://cert.vatsim.net/sso/ as your base URL?

Link to post
Share on other sites
Hi Aidan ,

Thank you for replying .

 

I use https://cert.vatsim.net/sso/

 

If you are using the production SSO and both stopped working at the same time, it seems like a firewall or DNS issue. Can you try pinging cert.vatsim.net from your server? If that fails, try pinging 5.9.159.186. If that still fails, let us know.

 

Hi ,

Unfortunately , i don't have the option to ping from the server (Hostgator shared hosting .... )

But there is another strange thing - i pinged my server and got completely different IP address from the one i see on cPanel ,

If i will give you in private message the ip address (the one i got when pinging) can you see if there was try to use VATSIM SSO from it?

Link to post
Share on other sites
Hi Aidan ,

Thank you for replying .

 

I use https://cert.vatsim.net/sso/

 

If you are using the production SSO and both stopped working at the same time, it seems like a firewall or DNS issue. Can you try pinging cert.vatsim.net from your server? If that fails, try pinging 5.9.159.186. If that still fails, let us know.

 

Hi ,

Unfortunately , i don't have the option to ping from the server (Hostgator shared hosting .... )

But there is another strange thing - i pinged my server and got completely different IP address from the one i see on cPanel ,

If i will give you in private message the ip address (the one i got when pinging) can you see if there was try to use VATSIM SSO from it?

 

Hi Or,

 

You can send me an email at [email protected] with your SSO client key and IP address and I can look into it for you. We’ll be sure to post the final solution here for future reference.

 

Regards,

Link to post
Share on other sites

Hi guys,

 

We are also experiencing exactly the same problem starting from about 1 week ago. The server is set up similarly to Or's. An email with client key and ip address has been sent to Aidan's email address.

Wenlue Zhang | Contact me

Senior Controller (C3)
P.R.China Division Webmaster (VATPRC8) 

spacer.png

Link to post
Share on other sites
  • 2 weeks later...

Just to update all following this thread, we have narrowed down the issue to HostGator shared hosting. There are no firewall rules on the VATSIM servers that are preventing these connections. We are in the process of working with HostGator to get traceroutes from their shared servers to find exactly where the connectivity issue is occurring.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...