Jump to content

P3D v4.3 CH-53E comms not working, is a battery required?


Recommended Posts

Hey guys, I dont think the CH-53E has an actual battery to run all of its systems. Does vPilot require the battery of the aircraft to be ON in order for comms to work? I cant even type on Unicom.

 

I tried to briefly look into it, and when I load another aircraft from the CH-53, the batteries are always off, I flip the switch and Vpilots' comms come alive. But as far as I know the CH-53 that comes with P3D doesnt have any battery to run the systems. i can tune all the frequencies just fine in it.

 

-Josh

Link to post
Share on other sites

vPilot reads the state of the master avionics switch to determine if the radios are on or off. I have run into this issue with several other aircraft. The solution is to [Mod - Happy Thoughts]ign a key combination to the avionics switch and use that to turn on the radions (I usually use shift-A).

Tomas Hansson

Link to post
Share on other sites

I [Mod - Happy Thoughts]igned a shortcut to Avionics Master and I do notice a small effect of a few instruments turning on and off, but makes no difference on the radios, vatsim comms are still greyed out on vPilot. The radios are on because thats how i tuned the frequency... unless i can tune the freq with the radios off somehow.

I also tried [Mod - Happy Thoughts]igning Master battery toggle, and still to no avail... Any other possible solutions, or if someone has flown the CH-53E on vatsim, how did you get the comms working???

Link to post
Share on other sites

It was a different heli, but, I ran into difficulty in the past when my default flight was cold-and-dark, and one of the dark systems in that scenario was a system that my heli needed not to be dark but didn't have a switch for.

 

Long story short, try loading up a default plane with everything powered & lit, and save that as your default flight. Close & re-open the simulator. Then select your Chinook & see if you have radios.

 

Not sure whether that will help but it's worth a shot...

Cheers,

-R.

fvJfs7z.png

Link to post
Share on other sites

The heli is a Super Stallion actually, by Nemeth Designs, but Lockheed Martin added it into their hanger of aircraft in v4.2.

I tried what you said though, made sure everything was powered up, saved as a default, exited, then relaunched and chose the CH-53.

Unfortunately that didnt work either, the aircraft spawned in cold and dark, and im sure its doing that because of some .dll gauge with the aircraft.

 

HOWEVER, I did manage to get the comms up on VATSIM with another method; default ATC! After turning on all the systems of the Super Stallion I opened up ther default P3D ATC window (with the "`" key), and tuned what ever frequency it said I could tune too. Once I clicked that, VPilots' TX RX symbols were no longer greyed out, and I simply tuned back to the unicom frequency. Unfortunately, no atc is online right now, so i cant fully check and see if this is indeed a good solution.

Link to post
Share on other sites

Well, it seems like the default atc window is not a viable solution to keep comms running on vatsim.

 

After a little while, it seems like the default atc tunes out of the frequency and vPILOT greys out its TX RX again.

 

I even retried to get them back up by restarting the simulator and following the same process I outlined in my message above, but I cant get vPILOTs freqs to work now.

Link to post
Share on other sites
  • 3 weeks later...

Yes, it is. However, the registered version also allows you to specify a different control setup for each different plane (or category of plane or what-have-you), which I find invaluable, so I considered that small investment money well spent. Your perception of value and mine may differ, of course, but it might also offer a solution to your radio power problem.

Cheers,

-R.

fvJfs7z.png

Link to post
Share on other sites
  • 8 months later...
  • 1 year later...

I found that if one changes the following setting in the aircraft.cfg under [electrical]:

From: avionics         = 1, 5 , 17.0
To: avionics           = 0, 5 , 17.0

Then leave the app in the starting position vpilot works with the Nemeth Design CH53. 

 

 

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...