Jump to content

Software needed to be a ATC


Recommended Posts

I notice that VRC is supposed to be a good one. I am wondering about this one.

 

Download Tower View Modelsets - Required for Virtual Tower View

 

In order to use the Virtual Tower View feature in VRC 1.1 or later, you will need to have the VIP multiplayer aircraft modelsets installed within FS9. If you already have Squawkbox 3 installed, then you don't need this. This installer (and the VRC Virtual Tower View) currently only works in MSFS 2004.

 

I am wanting to use FSX if I need it, and have the Virtual Tower View.

 

Thanks

 

Jim

Link to post
Share on other sites
  • Board of Governors

VRC no longer supports Tower View, and never did with FSX.

 

Both vSTARS and Euroscope offer a way to simulate a Tower View with FSX.

 

As has been mentioned, your facility training team will guide you with software selection once you've joined a local facility and are beginning training. That may steer you toward whether you'd be more likely to want to use vSTARS or Euroscope for Tower View.

Don Desfosse
Vice President, Membership

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...