Jump to content

X-Plane pauses for several seconds when using xpilot.


Tim Simpson
 Share

Recommended Posts

This has occurred in the two FNO's I've flown in using xpilot. As the number of pilots on frequency increases, X-Plane starts pausing randomly for 3 to 5 seconds. X-Plane just freezes, and then resumes again after the 3 to 5 seconds has p[Mod - Happy Thoughts]ed. This only happens when I'm logged in with xpilot, and only during high voice volume times during an event. I'll also note that it was two different aircraft (LES SAAB and Rotate MD80).

 

Has anyone else had this happen, or heard of it happening? It's making events not be very fun.

Link to comment
Share on other sites

This has occurred in the two FNO's I've flown in using xpilot. As the number of pilots on frequency increases, X-Plane starts pausing randomly for 3 to 5 seconds. X-Plane just freezes, and then resumes again after the 3 to 5 seconds has p[Mod - Happy Thoughts]ed. This only happens when I'm logged in with xpilot, and only during high voice volume times during an event. I'll also note that it was two different aircraft (LES SAAB and Rotate MD80).

 

Has anyone else had this happen, or heard of it happening? It's making events not be very fun.

At what stage of your flight is this happening? What CSL package(s) do you have installed? What are your system specs?

Controller (C3), Los Angeles ARTCC
Developer: xPilot, vATIS

Link to comment
Share on other sites

I get stutters no matter if I'm connected or not. I'll be glad when the Dev's get things smoothed out.

I'm not sure how you would get stutters from xPilot if it's not even connected to the network...

 

What are your system specs? What CSL package(s) do you have installed? What other plugins do you have installed?

Controller (C3), Los Angeles ARTCC
Developer: xPilot, vATIS

Link to comment
Share on other sites

At what stage of your flight is this happening? What CSL package(s) do you have installed? What are your system specs?

 

I'm at work....I'll answer back when I get home. One thing to note, I'd call the issue a pause, and not a stutter. A stutter is short lived, but motion continues. I'm seeing the sim just stop for 3 to 5 seconds, then start moving again smoothly.

 

I don't see this behavior with low user volumes, like on any non-event flight. Seems like it's either the number of pilots burdening xpilot, or, the number of controller connections that blooms during an event.

Link to comment
Share on other sites

I get stutters no matter if I'm connected or not. I'll be glad when the Dev's get things smoothed out.

I'm not sure how you would get stutters from xPilot if it's not even connected to the network...

 

What are your system specs? What CSL package(s) do you have installed? What other plugins do you have installed?

Windows 10-64 Bit

i7-4790k CPU @ 4.0Ghz

32GB RAM

Nvidia RTX2070 Super

 

Bluebell CSL Libraries

 

Airport Navigator

Autogate

Avitab

Betterpushback

FlyWithLua

SAM

TerrainRadar

WebFMC

XUIPC

X-RAAS2

 

I average 45+ FPS even in heavy weather, no micro stutters until Xpilot is installed.

 

Other than that, It works fine. Easy and seamless to use.

Link to comment
Share on other sites

i7-8700K @3.7GHz

RAM 16GB

GeForce GTX 1070

 

Bluebell CSL's

 

Plugins:

ASXPConnect

Autogate

Better Pushback

TerrainRadar

xPilot

X-Plane ATIS switch

XPUIPC

X-RAAS2

 

But to re-iterate, I didn't have these issues when using XSQUAWKBOX, only when switching to xPilot.

 

EDIT: It's happening at all stages of the flight. Taxi-TO-enroute-landing-taxi.

Edited by Guest
Link to comment
Share on other sites

Follow up:

 

Did a couple of test flights in the Oakland and Los Angeles ARTCC's, using all the plugins I normally use. I flew the Zibo and the ToLiss A319. With "normal" traffic levels, and a couple controllers on, there were no X-Plane pauses.

 

Then flew for a bit disconnected from the client offline, with no pauses either.

 

Clearly a client issue, or an overload of the audio server causing an issue with the heavy burden of an event.

 

FYI, the event was the Albuquerque FNO on 11-30-2019.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...