Jump to content

No audio on vPilot


Recommended Posts

Hello,

 

I recently downloaded vPilot again because I wanted to fly again on VATSIM. It has been over a year since the last time. I filled everything in. Selected my headset as output and my headset mic as input. I'm able to hear the private message notification and messages coming on frequency but I'm unable to hear the controllers talking, I can't hear the buzzer and don't hear anything when switching frequencies (I don't know if the last 2 things still exist on vPilot). This is frustating and I'm really looking forward to hearing the new realistic VATSIM voice comms. I hope this can be fixed.

 

Kind Regards,

 

Oskar

Link to post
Share on other sites
  • 2 weeks later...
I have a similar problem after I upgraded Windows7 to Windows10.

 

When the vPilot client WINDOW (on remote laptop) is NOT IN FOCUS then all voice IN and OUT is not heard.

When I bring it on top then I hear sounds.

Anyone know how to fix this ?

 

Try running vPilot as admin.

944416

Link to post
Share on other sites
  • 1 year later...

I just upgraded my CPU and when I connect to vpilot, I can transmit and be heard but cannot hear ATC. I only see RX illuminating when ATC transmits but no voice heard. 

Solved: With the new CPU came Sonic Sound, which seems to be the issue. I uninstalled it and now all is working well.

Edited by Faisal Saleh Alquraishi
Link to post
Share on other sites
  • 2 weeks later...

I have the following issue with vPilot.

After some considerable time passes (like 30~60 minutes) while on 122.80 without communications I realize that I do not RECEIVE any voice calls.

When later I tune in and TRANSMIT to ATC on line, I find out (by later asking) that ATC hears me but I do not hear them so the inbound calls seem to be blocked after some time of inactivity.

I close it, re launch it, connect and then it works (checking with ATC).

I run the client on the same single PC without any network remote setup.

Each time I launch it with right click, run as Admin.

I am the admin in the PC anyway.

I have the vPilot window visible on the side screen (extended desktop).

Audio devices are all properly set up and tested.

Just in case, I have set UDP Inbound & Outbound rules with port 3290 open but that did not change anything.

vPilot is already recognized and allowed in Windows Defender but I added the above rules anyway.

Is there something else I could set up with Windows Firewall rules ?

I do not have a separate software/hardware Firewall, only what Windows 10 provide i.e. Control Panel->Windows Defender Firewall->Advanced Settings->Inbound & Outbound Rules

Any clues ?

Windows 10, up to date updates,  vPilot always updated, Prepar3D v5.1, No other 3rd party antivirus etc.

spacer.png

Hellenic vACC | Olympic Air Virtual

Europe Region Director 2001-2011

Pilot: P5 | ATC: C3

Link to post
Share on other sites
  • 3 weeks later...

I've got something similar.

vPilot running as admin, I can hear ATIS and MSFS autocontrollers, the RX lights illuminate when I presume a controller or aircraft is transmitting, but I cannot hear anything myself. Defender is set to allow vPilot through, totally lost as to what to try next! It's getting tiresome to keep typing out the clearances when I'd just like to transmit and receive properly.

Earphones and speakers are set to the appropriate devices, password is all in the green...

Link to post
Share on other sites

You may want to try setting the audio output device in vPilot to your main speakers and see if that works, just to eliminate there is no issue with the headset.
I assume the sim sound is routed to your main speakers rather than the headset ?

944416

Link to post
Share on other sites
1 minute ago, Kyprianos Biris said:

In my case, Sim sound routed to external speakers, vPilot sound routed to headset.

I saw your post a couple of weeks ago Kyprianos, did you get your issue resolved ?   I was just suggesting that James try routing vPilot to his speakers to eliminate any issue with the headset.

944416

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...