Jump to content

ATC shows different Altitude with Mode C


Recommended Posts

I have an issue with about 70% of the controllers. When I connect to them an connect, I am showing an altitude that is about 20K to 40 k higher than what I am actually flying with my Swift Software. When I look at Vat spy I show the correct altitude that I am flying. Everything else is reporting fine. I toggle the Mode C and nothing happens. Then sometimes it auto corrects and other times it does not. I just keep reporting my cruise altitude. Need any suggestions as to resolve

Link to post
Share on other sites
  • 1 month later...
On 3/26/2020 at 10:46 AM, Andreas Fuchs said:

Hi Derrick,

 

what SIM are you using? What version of swift? If you are using X-Plane, have you installed xswiftbus with the same version number as swift?

Hi, 

I have a similar problem. ATC usually see me at different altitude than what my sim shows.

XPlane 11.50b9, FF A320, Swift 0.9.4.369, swiftbus is the same version.

Sometimes ATC sees me at one flight level above when in cruise (with standard qnh), during approach 300 feet below my indicated altitude (happened to me yesterday during approach, the whole time ATC was reading me 300 feet below).

I use ActiveSky for weather.

For the screenshot below I set the ActiveSky to use vatsim weather, qnh is 1023, you can see the xplane two altitudes, they differ very little, the transponder is On (not Auto) - and this is confirmed in the Cockpit tab of swift, Mode C. The "Altitude pressure" of Swift shows about 300 feet below what is my indicated in xplane altitude. After the issues yesterday during the approach, I tried for the next flight to use xpilot and then during flight checked with the ATC, this time my altitude was perfectly correct.

 

2020-05-23 22_31_37-X-System.jpg

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...