Jump to content
Robin Tannahill

Swift with Vulkan

Recommended Posts

The new X-Plane 11.50b1 with Vulkan gives really impressive frame rate increases (good bye "we're going to disconnect you" messages?)

 

However, it would appear that, with Vulkan, none of the VATSIM or IVAO pilot clients display other on-line aircraft, which, in most circomestances makes on-line flying a no-no. I am presuming that work is underway with Swift to make this excellent program compatible with Vulkan as I am sure that when 11.50 is released as a non-beta most folks who can will choose Vulkan due to the performance improvement.

 

So, really, this post is just to seek confirmation that work is ongoing to make Swift a Vulkan compatible program?

Thanks again for a really nice pilot client!

Share this post


Link to post
Share on other sites

Hi Robin,

 

actually Justin, the developer of xPilot, has been in touch with the developers of swift (and I presume also with Chris from xSquawkbox), sharing some findings on how to approach these challenges. I do not want to lift anybody's hopes too much, so there is no time-line or similar. Just confirmation that it is being worked on in one way or the other.

Share this post


Link to post
Share on other sites

Thanks so much for the "Swift" reply! I really look forward to this development. To be honest, it's just frustrating to have at least 50% extra fps to play with and not being able to take advantage of it on line! Thanks again for you efforts , Robin

Share this post


Link to post
Share on other sites
Guest Andries Gouws

Hi is there any news when this problem will be resolved..........

Share this post


Link to post
Share on other sites
Posted (edited)

I can connect swift 276 with X-Plane 11.50b4 and it appears to work in all respect except actually rendering other aircraft on my screen.

Voice works with controllers. Other aircraft are shown on  the swift radar. Aircraft, ATC and User lists appear to be correct.

The Models list indicates Rendered aircraft are being rendered.

Is this swift?

Or am I missing something?

Do you need any files?

 

 

Edited by Richard Quigley

Quig, C3, P1, VATPAC, CZQM (inact), CZQX (ret).

4200+ hrs of "Chaos, Panic & Disorder in your virtual skies!"

 

0.png

Share this post


Link to post
Share on other sites
Posted (edited)

It is xPilot Andreas. 

But I like swift!  It a great many very useful features.

Edited by Richard Quigley

Quig, C3, P1, VATPAC, CZQM (inact), CZQX (ret).

4200+ hrs of "Chaos, Panic & Disorder in your virtual skies!"

 

0.png

Share this post


Link to post
Share on other sites

Aha... Please update the documentation on :

https://dev.swift-project.org/w/help/swiftgeneral/notrendered/

This could save people like me hours of search and frustration...

Thanks, I now have the reason ;-)

 

Share this post


Link to post
Share on other sites

Good morning i HOPE that the PROBLEM with Vatsim and Swift will be fix very Quickly........every time i reach and airport and want to switch over to the controllers SWIFT starting to stagger....and you CAN NOT talk to the controllers, and then i have to disconnect.........

Share this post


Link to post
Share on other sites
1 hour ago, Andries Gouws said:

every time i reach and airport and want to switch over to the controllers SWIFT starting to stagger....and you CAN NOT talk to the controllers, and then i have to disconnect.........

Hello Andries,

what simulator and what version of swift are you using, exactly?

Share this post


Link to post
Share on other sites

I am using the same, I do not have these problems.

What exactly do you mean that swift starts to "stagger"? Is the voice broken or like a robot? Does swiftGUI freeze? Are you able to talk to other pilots on UNICOM 122.800 when there is no ATC?

Share this post


Link to post
Share on other sites

Hi yes its like a robot the voice but i battle to switch over to freq........my ptp talk button reacts slower......and when i zoom into the radar menu it staggers.......it does it to all the servers....yes i can talk to others on unicom.......it looks like it freezes......even battle to scroll to diff freq.......

Share this post


Link to post
Share on other sites

No im not on  Discord , it was working but as soon as Xplane 11 went over to Vulcan its a ............ so yes i hope they sort it out......soon. The purpose is to fly online......the controllers think you stupid if you cant answer them straight away after instructions......and then you have to disconnect......

Share this post


Link to post
Share on other sites

Ok, I am stupid. I thought you were using X-Plane 11.50 in OpenGL and not in Vulkan (because it does not work yet with swift, as explained in the first few posts of this thread).

Just to be sure: swift does not support Vulkan yet. If you would like to continue using Vulkan, you'll have to use xPilot. Maybe even xSquawkbox works with it already, but you'll have to check the forum and the XSB-website for it.

Share this post


Link to post
Share on other sites

Im using Xplane 11.50b6 in OpenGL......I know it doesnt wotk with Vulkan......does xPilot work with Vulkan........

Share this post


Link to post
Share on other sites

Which audio driver do you use? Please have a look into C:\Program Files\swift-0.9.4-64bit\bin\audio. Is there more than a "qtaudio_windows.dll" file?

Share this post


Link to post
Share on other sites

Ok,,,,so i hope that vatsim can fix this problem very soon, the servers cant handle all the pilots at the moment.....see all different problems......pilots are having......

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...