Jump to content

XsquawkBox + XPlane + Linux - No Audio

Recommended Posts

I have the following:

XPlane 11.41 64bit

Linux Lmint 19.3 64bit

XSquawkBox 2.1 VATSIM

XSB Audio Setup: Audio API - ALSA, Input: pulse, Output: default (also tried pulse), Enable Radio Effects checked and unchecked)

XSB vu meter shows microphone being picked up.

In Xplane, I hear the engine audio and tuning to a VOR I can hear the ID.  I have enabled in the XSB the push to talk mapping to the flight yolk PTT button.  I can hear controllers as I select the correct frequencies as shown in the who's on-line window.  However, I never get a response.  How can I test/trouble shoot?  I have read the manuals and think I got all correct.

Link to post
Share on other sites

Truly bizarre.  I can transmit but I have to have both radios turned to the same frequency and have both COM1 and COM2 selected (C172SP).  If I only have COM1 selected on the audio panel I only hear the audio background noise of the open mic when I release the PTT.  If I have COM2 selected and COM1 off then I hear nothing at all.  If I have COM1 and COM2 selected for audio then it works but the echo in the headset is very loud, delayed, and makes it almost impossible to talk it is so disturbing. 

Link to post
Share on other sites
  • 4 weeks later...

OK. everything used to work but now nothing.  Very unstable.

I can verify that I am connected to VATSIM using VATspy.  No one responds, I cannot hear my delayed transmission in the second radio and I have tried all possible configurations in the sounds settings.  In the sound settings box I can see that my mic is working.

OS: LMint V19.3, Kernel: Linux 5.3.0-59generic x86_64

XPlane: 11.41

updated Squawkbox to 2.1

I have attached the log.txt from XPlane.

the only thing that I can see in the log file that concerns me is in the section of the log where XSB is starting there is a line:

XSB:AL: Sample is 10469 samples, 44100Hz, 16 bits, 2 channels

but later in the log, there is a line:

XSB-AFV-Native: Sat Jun 13 11:32:55 2020: AudioDevice: Opening 1 Channel, 48000Hz Sampling Rate, 960 samples per frame

which looks to be a different sample rate.  Is this confusing ALSA?


There are also several "heartbeat timeout" lines.  So what is going on here?


This is a real devil to debug!

Log (copy).txt.pdf

Link to post
Share on other sites

Solved.  But not sure how.  I reset the WiFi/cable modem and everything works now.  Never did any config changes in the Modem so I am not sure how anything changed.  Perhaps just a case of refreshing with the ISP.  We wiil never know.  Impossible to trouble shoot that.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...