Jump to content

Couldn't tune to COM1 frequency in vPilot for MSFS


Recommended Posts

Hi. This is really weird.  I was doing a simple traffic pattern around CYVR (Vancouver International) today in a Cessna 172, G1000.  I had tuned to 118.7 fine on the ground and was talking to Tower all the way to takeoff.  I took off from runway 08R at CYVR, and then did the normal right hand traffic pattern there.  On final, I asked for clearance to land on Runway 08R.  Tower at CYVR did not respond.

So I checked my frequency.  For whatever reason, my frequency in MSFS had changed and Tower didn't hear me.  In vPilot, I typed ".com1 118.7" as you can see in the screenshot.  However, the frequency in MSFS stayed at 120.8 in vPilot and it stayed as 120.8 in MSFS, as also shown in the screenshot (the screenshot shows my go around because I didn't get clearance to land on my original attempt at final):Com1_Bug.thumb.png.935eba64f2711701b539b9cae3e06684.png

I even tried to tune 118.7 in MSFS via the Com knob on the G1000.  But that didn't seem to work either.  No matter what, I could not tune 118.7.

Is this some bug with vPilot?  The only thing I can say is that during my traffic pattern, a rush of controllers joined CYVR, presumably for the Vancouver VATSIM event today.  When my flight started out, it was just me and Tower at CYVR (there was also somebody manning CZVR Center when I started out but I didn't have to tune to CZVR Center).  In the middle of my flight, you can see that a lot more controllers joined.  My guess is the rush of controllers joining triggered some bug in vPilot - but I am not sure, maybe it was something I pressed in MSFS (although I don't recall pressing anything out of the ordinary during my traffic pattern).  This has never happened to me before, it's really weird.

The one thing I do remember though is that when I typed ".com1 118.7", vPilot briefly showed for a split second that I was tuned to 118.7 on the top right of the vPilot window, but then it automatically flipped to 120.8.

 

Edited by Richard Lee
Link to post
Share on other sites
6 hours ago, Robert Shearman Jr said:

In settings and "assistance" there is one called "delegate ATCs to AI" or something along those lines.  Ensure it is OFF.  Otherwise your pretend First Officer will spend the entire flight messing with your radios and transponder. 

Thanks.  I think this was likely the problem.  I had enabled "Manage Radio Comms" in the "AI Control" window.  Maybe the developer for vPilot can do a check to see if "Manage Radio Comms" is enabled and if it is enabled, flag a warning in red on the console when vPilot connects to the network.

Edited by Richard Lee
Link to post
Share on other sites
8 hours ago, Ross Carlson said:

I don't see how this could be a bug in vPilot, especially if you can't tune the frequency in the aircraft. Plus, there have been numerous other reports of radio tuning problems with the new MSFS.

Hi.  Are you the developer of vPilot?  If so, would it be possible in a future version if vPIlot to issue a warning in red text, as Robert Shearman Jr has noted, if vPilot detects that the AI has been selected to manage the ATC comms?  Some of us may have "Manage Radio Comms" selected in the "AI Control" window (please see the screenshot of the "AI Control" window).  If MSFS is able to give vPilot the information of whether "Manage Radio Comms" is enabled or disabled, then vPilot could issue a warning in red on the console when we connect with vPilot to the VATSIM network.  If that would be possible in a future version of vPilot, that would be very helpful.  Thanks.

ManageRadioComms.png

Edited by Richard Lee
Link to post
Share on other sites
2 hours ago, Robert Shearman Jr said:

He is, and I'm sure he will answer on his own behalf.  But, I doubt vPilot has any way of detecting that setting, as I'm guessing it's not a setting that would be transmitted thru SimConnect. 

Ok, I will let Ross respond.  But yeah, if it's not a setting that is transmitted through SimConnect, I guess nothing can be done about it from the perspective of vPilot.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...