Jump to content

Can't See VSCS or Text Communications Box


Recommended Posts

I installed vERAM and closed it. The next time I opened it the VSCS or the Text Communications box have disappeared and I can't get them to come back. I am running the program as an administrator. I also have a multi monitor setup and had them on the other monitor.

logo2.png.90a40c2564324860397e893f65cf8c08.png

          Controller 1

Link to post
Share on other sites

vERAM should be automatically moving any off-screen windows to your primary monitor. If that's not happening, then there must be something special about your system that is preventing that code from working.

The best I can suggest is to open your vERAMConfig.xml file and manually edit the following sections:

  <CommsWindowProperties Maximized="false" FullScreen="false" TopMost="false" NormalBorderStyle="None">
    <Location>
      <X>351</X>
      <Y>149</Y>
    </Location>
    <Size>
      <Width>602</Width>
      <Height>488</Height>
    </Size>
  </CommsWindowProperties>
  <VSCSWindowProperties Maximized="false" FullScreen="false" TopMost="false" NormalBorderStyle="None">
    <Location>
      <X>457</X>
      <Y>740</Y>
    </Location>
    <Size>
      <Width>602</Width>
      <Height>502</Height>
    </Size>
  </VSCSWindowProperties>

You can find that file by opening the following folder:

C:\Users\<your user name>\AppData\Local\vERAM

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Going back into the config file I was able to move them to my main monitor.

This issue also presents itself for secondary displays. If I move them to my second monitor they no longer show when I restart vERAM.

This issue makes vERAM unusable to me. Is vERAM not coded to work on two monitors?

vSTARS works perfectly fine across both of my monitors.....

Edited by Ike Callaway

logo2.png.90a40c2564324860397e893f65cf8c08.png

          Controller 1

Link to post
Share on other sites
34 minutes ago, Ike Callaway said:

Is vERAM not coded to work on two monitors?

It is. Many people use it on multiple monitors every day. There's just something about your system that is preventing it from working. Others have run into the same issue, so it's not just you. I haven't been able to figure out what's causing it yet, but I suspect it is some combination of Windows patch version, and the video card driver version.

34 minutes ago, Ike Callaway said:

vSTARS works perfectly fine across both of my monitors.....

That's strange ... usually if this issue occurs with vERAM, it also occurs with vSTARS.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...