Jump to content

AFV Controller Client Unusable


Recommended Posts

Hi all, 

This is an issue which has been bugging me for quite some time and nobody has even attempted to help so far.

The issue I have is that I open AFV client and connect but it will not allow me to transmit, I have tried changing PTT so various options but the client almost always crashes when trying to change, occasionally if I persist I can change and I have tried different PTTs and still no ability to transmit. 

Does anyone have any ideas?

Any help would be appreciated! It means I can only control on rare occasions where it decides to work

 

Link to post
Share on other sites

I can try to guess at a few things and see if they help. I'm in no way affiliated with the AFV Team and (to borrow a favorite phrase of Don's), I can barely spell "code", let alone write it.

For me, the AFV client won't allow changes to settings after it's been connected. I need to choose a PTT once, before connecting. If I try to change the PTT, I usually have to close the entire client and start it again. 

Make sure you're running the AFV client as administrator. 

If you do manage to get connected, could you send us a screenshot of AFV when you're trying to transmit? 

spacer.png

Evan Reiter
Boston Virtual ARTCC/ZBW Community Manager

 

Link to post
Share on other sites
  • 1 month later...
On 12/17/2020 at 6:14 PM, Evan Reiter said:

I can try to guess at a few things and see if they help. I'm in no way affiliated with the AFV Team and (to borrow a favorite phrase of Don's), I can barely spell "code", let alone write it.

For me, the AFV client won't allow changes to settings after it's been connected. I need to choose a PTT once, before connecting. If I try to change the PTT, I usually have to close the entire client and start it again. 

Make sure you're running the AFV client as administrator. 

If you do manage to get connected, could you send us a screenshot of AFV when you're trying to transmit? 

Hi Evan thanks for the reply, didn't get a notification for some reason, only just seen.

Still having the issue.

The client for me is always run in admin, I have also tried not running in admin.

It works 50% of the time. On the times when it doesn't work; when I press the PTT nothing happens.

image.png.31efde389dc962729b57ba04fb2c3bfe.png

As you can see it looks normal but I was pressing the PTT as I took the screenshot.

Also, I ran he program just beforehand to test and it worked, restarted the client and also Euroscope and it didn't work, it really is pot luck.

I have tried changing PTT which is also difficult as the client crashes 90% of the time when attempting to do this, on the times I have been successful it has not fixed the problem. 

 

Much appreciated

Link to post
Share on other sites

(Also not affiliated with AFV)

This sounds related to my experience using AFV--particularly the part about the program crashing when setting a new PTT. What I've been doing lately is opening up AFV as administrator (before connecting to the network), clear out the current PTT then set the new PTT, click "Apply", and finally "OK".

My PTT is a foot pedal that I recently bought and for some reason I have to go through this process every time I start AFV. This has been the most reliable method of getting AFV up and running that I've been able to figure out, so far. 

Link to post
Share on other sites
  • 2 weeks later...

Hi Gary,

Deleting the client config works on a one time basis, if euroscope or the client is restarted then the issue returns.

But its good enough to keep me going, thanks!

If there something I can do to prevent having to delete the config everytime?

Many thanks

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...