Jump to content

Nametags/Nameplates/Labels not working in MSFS with V-Pilot, etc.


Recommended Posts

It does not seem like labels are working in MSFS with any third party multiplayer service. While this may not be as important for Vatsim, it is more important in other areas, and I think at least allowing pilots to have the option to use labels would be nice. Even if they do not transmit secondary data such as speed, heading, and altitude.

Why am I asking here? I have searched the internet and found no good information. I know Vatsim has a relationship, or at least a line of communication with Asobo to hopefully help resolve this.

What I know so far is it seems Simconnect is not transmitting label information in the new MSFS. What I would like to know is if it is possible to make labels work in third party multiplayer clients? If not, can we try to get Asobo to add this in? It might be very simple for them to add this functionality, and could have easily been left out.

Also, maybe I am missing something, and in that case, please let me know how to fix this. We are a community and the goal of this post is to help each other. I hope the people reading this will help in anyway they can. Thank you.

Link to post
Share on other sites

I don't have a resolution for this issue yet, but I just want to point out that it's not a question of SimConnect transmitting information. In other SimConnect sims, the labels are created automatically when the client software creates the simobject. For whatever reason, MSFS does not do this. I haven't researched it yet, to see if there is some other way through SimConnect to cause the nameplates to appear. This hasn't been a priority since the nameplates are huge and most people I've talked to wouldn't turn them on anyway. I know there are community add-ons that make them smaller, so that'll help.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Yes, the community add-on helps significantly. The default are obnoxious, mostly the grey background.

If anyone can help or contact Asobo, that would be great. Otherwise I am down to putting up a feature request and praying for votes. Maybe fixing the labels and getting third party to work would be great. I would assume the "partnership" may have some weight here. And since I would imagine at this point, Vatsim probably does not ask for much in development terms, maybe there is a better chance we can help make the sim better for everyone, even in general.

Edited by Travis Albrecht
Link to post
Share on other sites

Hi, Ross. We are waiting for a transponder update and better integration. We need Mode C from transponder button! Please ask to ASOBO for it again. Insist about it!!! 
Of course, labels are important too. Small labels with a little font with yellow colour is enough.
Thanks & Regards.

Link to post
Share on other sites
11 minutes ago, Rafael Santos said:

Insist about it!!!

Umm, no. That is not the way to have a respectful dialog with fellow developers.

Anyway, Mode C is already available. I'm just waiting for Asobo to reply about how to detect the IDENT button press. Then I'll have a vPilot update that handles both Mode C and IDENT. I only sent the question a couple days ago, and it's the weekend. The dev team lead forwarded it to the other developers right away, so now I'm just waiting to hear back, and I expect it'll be soon.

Edited by Ross Carlson

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...