Jump to content

Drastic performance drop when connetcing to VPilot


Recommended Posts

I have noticed that when I connect to Vpilot fps goes from 55 to 35, gpu from 99% to 70%. Sometimes when I am flying as soon as Vpilot catches atc coverage gpu can drop from 60% to 30% usage, thus making it unplayable. I use MSI afterburner to monitor the performance and clearly something is off. At first I thought it was a MSFS update , but after flying around 40 hours without Vpilot without having any performance issues, I am now certain it's Vpilot causing it.  

 

Edited by BRIAN MUJICA
Link to post
Share on other sites
  • BRIAN MUJICA changed the title to Drastic performance drop when connetcing to VPilot
On 1/29/2021 at 5:32 PM, BRIAN MUJICA said:

as soon as Vpilot catches atc coverage gpu can drop from 60% to 30% usage

That doesn't make any sense ... I don't see how being in range of ATC can have any effect on your GPU usage.

Does this happen only when there are other aircraft nearby (check the .aircraft list) ?

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites
3 hours ago, Robert Ericsson said:

I have this problems too in P3DV5.

Tried just now to fly from London, 45 fps without Vpilot/Vatsim, 20 fsp online.

Is it Vpilot or Vatsim who causes this?

Check your model matching as you don’t want to use for example fslabs models for ai.

Link to post
Share on other sites
  • 2 weeks later...
On 2/4/2021 at 8:42 PM, Ross Carlson said:

That doesn't make any sense ... I don't see how being in range of ATC can have any effect on your GPU usage.

Does this happen only when there are other aircraft nearby (check the .aircraft list) ?

It did not make sense for me either, I just did not know what was really happening. It's been almost a month and I have not encountered any problems with Vpilot. It has been overall a good experience. However, I reduced the aircraft display distance and the amount of aircraft to display. I am not an expert on the software but I did notice that performance decrease when there's significant amount of traffic (as expected). Sorry for the inconvenience.

 

Link to post
Share on other sites

As additional info, make sure that your model matching excludes any incredibly detailed add-on planes, and includes only "AI models" (stripped-down models which, by design, appear good enough from the outside but include no interior modeling, cockpit systems, etcetera).  Your pilot client does not need to spawn in 15 iterations of a fully-modeled detailed plane (FSLabs, PMDG, etcetera) which you'll only be seeing from dozens or hundreds of yards away.  Doing so is not only a practical waste but can significantly impact FPS. 

Cheers,

-R.

fvJfs7z.png

Link to post
Share on other sites
On 2/4/2021 at 10:42 PM, Ross Carlson said:

That doesn't make any sense ... I don't see how being in range of ATC can have any effect on your GPU usage.

Does this happen only when there are other aircraft nearby (check the .aircraft list) ?

I also have noticed 5-10 frames drop when connecting to the network, with no atc but some VATSIM traffic. This started to happen after the latest FS2020 update.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...