Jump to content

Recommended Posts

I recently updated vSTARS to 1.3.0, and am now having a problem with my PTT devices.

I have found when controlling that if AFV client or vATIS have focus, my PTT device does not work for other programs, like TeamSpeak.  It's an annoyance, but I deal with it.

When I installed vSTARS 1.3.0, I started having this issue with vSTARS as well.  I tried configuring my PTT pedals as a joystick device and a keyboard, but neither seems to fix the problem.

In the meantime, I have reinstalled 1.2.0.

Link to post
Share on other sites

Hi Dennis, 

I've experienced the same. I was told by some other ZNY guys that it is a TeamSpeak issue. Run TS as administrator, that fixed it for me. My understanding is that it has nothing to do with the radar client. (I don't use vSTARS and it still happened).

Edited by Sebastien Bartosz

New York ARTCC

Link to post
Share on other sites
51 minutes ago, Sebastien Bartosz said:

Hi Dennis, 

I've experienced the same. I was told by some other ZNY guys that it is a TeamSpeak issue. Run TS as administrator, that fixed it for me. My understanding is that it has nothing to do with the radar client. (I don't use vSTARS and it still happened).

That was my first thought, but he is implying that it works fine with vSTARS 1.2, which would mean it's a different issue, perhaps something caused by security software settings. That's why I asked my follow up question.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

I'm referring only for the ability for me to use a device as a PTT with Teamspeak while using some of the VATSIM software.

I'm hesitant to run any program as an administrator to fix a problem.  The only programs that seems to cause this issue with TeamSpeak are AFV Standalone Client and vATIS (and vSTARS 1.3).  VRC, Firefox, VAT Spy and other random programs I have running while controlling don't seem to cause this.

I brought it up in the vSTARS forum because it was a new behavior for me with the new version of vSTARS, and was only an inconvenience with the other programs.

Link to post
Share on other sites
3 hours ago, Dennis Graiani said:

I brought it up in the vSTARS forum because it was a new behavior for me with the new version of vSTARS, and was only an inconvenience with the other programs.

Are you 100% sure this issue only happens with vSTARS 1.3 and it does not happen with 1.2? I don't see how that's even possible, assuming you aren't configuring any PTT in vSTARS itself, and assuming you are not running vSTARS as an admin.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...