Jump to content

VAT-Spy would not run.


Andreas Libach
 Share

Recommended Posts

Hi, I am having a problem with the VatSpy application, after downloading VatSpy via the setup file, it launches perfectly, but if I close it and try to re-open it via the shortcuts literally nothing happens, but if I go to the folder where it is downloaded, and open the application it shows an error message stating: "The VAT-Spy application data folder does not exist! Please reinstall VAT-Spy", I have several times tried to re-install vat-spy but without luck.

Thanks in advance.

Edited by Andreas Libach
Link to comment
Share on other sites

The problem is that if you run the installer using credentials other than the credentials you used to log into the computer, then it will install the configuration and data files in the application data folder that belongs to the administrator account. Then, when you run the application, it will run as your regular non-admin user, and look in your application data folder and not find the configuration and data files, because they're not there.

So, you have to run the application using the same account that you installed it as. You can right click the icon and choose "Run as Administrator" and then enter the same credentials that you entered when you installed it.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

I am having the same problem.   I only have one administrator which is me and I do have it setup to run as administrator.   What I have been doing to work around is deleting the XML file in the VAT-Spy roaming folder in AppData.  Any help would be be appreciated

 

Link to comment
Share on other sites

37 minutes ago, Roderic Saunders said:

I am having the same problem.   I only have one administrator which is me and I do have it setup to run as administrator.   What I have been doing to work around is deleting the XML file in the VAT-Spy roaming folder in AppData.  Any help would be be appreciated

 

Do you run VAT-Spy on a secondary monitor?

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

Just posted a new bug for this:

When having VAT-Spy on a second monitor to the left in Windows 10 it records its position to VATSpyConfig.xml like this:

  <LastWindowLocation>
    <X>-1926</X>
    <Y>331</Y>
  </LastWindowLocation>

If you close VAT-Spy and then try to reopen it like this it will freeze and not start.

Removing the above section from VATSpyConfig.xml solves the issue and it starts perfectly on the right screen at x=0, Y=0 the next time.

My assumption is that the <X>-1926</X> causes the issue.

Link to comment
Share on other sites

  • 1 month later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...