Jump to content

Please help me getting VATSIM audio...


Simon Prinze
 Share

Recommended Posts

I installed vPilot a few days ago and wanted to jump into VATSIM. But i already tried hours getting the Audio to work. its getting really frustrating...

I choose the "receive only" option, but i cant hear anyone. Not the other pilots, not the ATC. Only thing i can do is transmit and receive via Text, even the ATIS gets displayed as text. i asked for numerous voice transmission checks from the atc, but i cant hear them. but i want that audio, what am i doing wrong?! Am tried on multiple airports with huge activity. i get sounds for receiving messages too. besides, i have never seen the RX button color up....

Do i have to change some settings in the MSFS 2020 options? Or is there a problem with the plane i am using (CJ4 working title)? am i forced to use headphones and microphon to "receive only"?

I already tried running vPilot as admin and i checked the output device (my speakers). i found another fix and looking in my windows firewall settings, but i cant even find xPilot there in my apps

Are there any other fixes? Thanks in advance

Edited by Simon Prinze
Link to comment
Share on other sites

In the CJ4, audio panel is on the left.  Make sure COM1 is selected to transmit and volume knob beneath it is rotated clockwise to "volume on & up" position.  Attach a screenshot confirming this is the case.  Aircraft and avionics must be powered on for vPilot to transmit and receive audio, also.

Attach a screenshot of vPilot also so we can confirm you are connected and that radio state indicators are white (powered) and that you are in range of the controller you're trying to reach.  Text range and voice range are different, FYI. 

Finally, if the above doesn't lend any useful info, it may end up being a firewall issue with the audio data port.  Your anti-virus may need to allow the app through, or, to open a certain port for data.  Can't remember what port but searching the forum for "AFV firewall" might help. 

Cheers,

-R.

fvJfs7z.png

Link to comment
Share on other sites

Simon, I had this problem and still have to juggle my sequence of settings to overcome this. The main problem I had was that I inherited an audio control system associated with my Asus motherboard. Sonic Studio 3. Disabling that through the Control Panel Device Manager cured the main obstacle but then I have still to juggle my sound settings via Windows Control Panel sound settings, playback and recording options and also their property settings. Also adjusting the selections in Start - Settings -Sound, including the Advanced Sound options.

All this is to ensure you have only your headset and mic selected. I found having external speakers working produced horrible feedback and static. A tip to check you are TX and RX is to select Unicomm 122.800 on Com 1 and 2, have both radio buttons on your comms panel selected and volume turned up. You should see Comm 1 TX and RX, and Comm 2 tuned to 122.800 and lit on Vpilot. Use your PTT function and Comm 1 TX and Comm2 RX should lit up blue and you will hear yourself transmitting..  

Edited by Ian Chalmers
Link to comment
Share on other sites

Screenshot

This is a screenshot of me using vPilot. Correct frequency is set, atc is in range, cj4 comms panel is all set up (actually it doesnt matter at all in receiving Vatsim due to CJ4 discord help) , firewall settings are checked and i have "receive only" checked. Audio output settings are correctly set to my speakers, i am not using  a headset or micophone. I have never seen the TX sign light up but i am receiving other notification sounds for messages. just no ATC other pilots voice.

Link to comment
Share on other sites

The frequency at the top right isn't in a blue colour so you're not connected to the controller.   I see you have your avionics off there - what happens when you switch them on?  Does the frequency numbers now change to a blue colour?

Trevor Hannant

Link to comment
Share on other sites

I think i have never seen the frequency change to blue. Even when i am chatting with atc in a fully ready aircraft with avionics turned on. 

I would love so much to use vatsim and hear the others voice....😔

Link to comment
Share on other sites

Simon, have you read the tips and tricks thread? particularly the info about installing with and without admin rights and also using admin rights when running the program. There is something about if you are using a keyboard PTT. Not using admin rights at the correct time apparently does weird things to VATSIM. 

Link to comment
Share on other sites

26 minutes ago, Ross Carlson said:

The fact that the TX/RX letters are white means the avionics are powered. The frequency not being blue means that vPilot could not connect to the voice server. Usually this is accompanied by an error message of some kind.

Actually there is a red error message everytime that i connect. It says that i have not plugged in a microphone and therefore cant connect to the voice server.

But i am using "receive only". Do i still need a microphone to hear other people????

 

Link to comment
Share on other sites

2 hours ago, Ross Carlson said:

Yes, the audio system will not function without an input device (microphone).

Oh god, it finally worked..i had to plug in a mic and set a output device, even though i just wanted to play "receive only"

Thank you all for the help!

Link to comment
Share on other sites

10 hours ago, Simon Prinze said:

cj4 comms panel is all set up (actually it doesnt matter at all in receiving Vatsim due to CJ4 discord help)

Glad you got it sorted, but just to clarify, the audio panel in your aircraft (yes, even the WT CJ4) must be set to transmit and receive, as vPilot will indeed read the state of that panel and simulate the state of the radios accordingly. 

Cheers,

-R.

fvJfs7z.png

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...