Jump to content

How does one network x-Pilot?


Robert Halmich
 Share

Go to solution Solved by Justin Shannon,

Recommended Posts

x-Pilot will not connect to X-Plane on a slave computer.

I installed and configured x-Pilot and CSL on the X-Plane (slave) computer and installed a second copy of x-Pilot on the master computer which is networked with the slave computer. I typed ".visualip 123.123.1.123" (not my real ip) and restarted x-Pilot on the master computer and it would not connect whether x-Pilot was running on the slave or not.

I uninstalled/reinstalled x-Pilot again on both PC's and left the path blank when the step to install the CSL library came as it was already installed into X-Plane 11\Resources\Plugins.

Does anyone have any suggestions to get x-Pilot to connect via the master computer?

Thank you in advance.

Robert

Edited by Robert Halmich
Link to comment
Share on other sites

  • Solution
Posted (edited)

xPilot doesn't have a true master/slave functionality like vPilot does; only one copy of the actual client needs to be running. However, you can configure it to run on a different computer and/or configure additional "visual" computers.

Install the xPilot client on the machine you want xPilot to be running on. If it's installed on a different machine than where X-Plane is installed, type the command .simip 1.2.3.4 (where 1.2.3.4 is the IP of the machine where X-Plane is running). If xPilot is running on the same machine as your master X-Plane instance, no need to specify the simip.

If you have a master copy of X-Plane and multiple "visual" computers, then you can enable the visual computers by typing the command .visualip 1.2.3.4 (again, replacing 1.2.3.4 with the IP of the X-Plane visual machine. If you have multiple visual machines, separate the IP's with spaces, so .visualip 1.2.3.4 1.2.3.5 1.2.3.6).

Be sure to restart the xPilot client after configuring the simip and/or visualip.

The xPilot plugin needs to be installed on each instance of X-Plane for this to work. It's probably easiest to just run the installer on each machine but only launch the xPilot client on the machine where you want to use the client.

Hope this helps.

Edited by Justin Shannon

Controller (C3), Los Angeles ARTCC
Developer: xPilot, vATIS

Link to comment
Share on other sites

  • 1 month later...

You got that error because you weren't connected to the network before trying to file your flight plan.  To file a flight plan through your pilot client, you need to have your sim booted up, plane parked in a non-movement area at the airport, xPilot running, connected to VATSIM.

Also -- your problem had nothing to do with the topic of this post, so, consider starting a new thread for a new question next time.

Cheers,

-R.

fvJfs7z.png

Link to comment
Share on other sites

  • 3 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...