Jump to content
PLEASE READ - Webmaster Support Forum
This forum will be retired in the near future. Please direct all queries to our dedicated GitHub support page https://github.com/vatsimnetwork/developer-info/discussions 
Here you can find documentation on our services and we are continuing to migrate pertinent information into the Wiki pages https://github.com/vatsimnetwork/developer-info/wiki

Ongoing problems with session logging in the API?


Jens Baumeister
 Share

Recommended Posts

Good day!

Apologies, if these are already known issues, but I couldn't find any mention of them and didn't see anything on the status page, either:

1) Trying to use the facilities endpoint to get the sessions of a position currently produces an error page. E.g., calling https://api.vatsim.net/api/facilities/EGKK_APP/ returns a page with the event ID a07ec990546440178d9d31684924b80a

2) The list of online facilities returned by https://api.vatsim.net/api/facilities/ seems highly outdated. All of the session it shows started on yesterday (Aug. 10th 2021) morning, i.e. more than 24 hours ago.

3) On a (probably) related note, http:/stats.vatsim.net/ also does not seem to list any sessions that happened later than early Tuesday morning. Compare, e.g., the results of https://stats.vatsim.net/search/EDDB_N_TWR and https://statsim.net/atc/positionsession/?callsign=EDDB_N_TWR  : The statsim.net list includes several sessions on Aug. 10th, all of which are missing from stats.vatsim.net 

4) Similarly, calls to https://api.vatsim.net/api/ratings/<cid>/atcsessions/ don't return any session later than early Tuesday morning.

It looks to me like there's a server side issue somewhere there which is probably responsible for all of these. I'd be grateful, if someone could look into it or tell me what I've been doing wrong.

Thank you!

Edited by Jens Baumeister
Link to comment
Share on other sites

 Share

×
×
  • Create New...