Jump to content

vPilot question related to receiving voice ATC


Tommy Rosengren
 Share

Recommended Posts

Hi!

I am a new player but having trouble to hear any voice. I tune to the ATIS of the airport to check if I receive something, but hear nothing. I do not hear any voice at any other channels as well. The only thing I hear are the short noice when a text message is received, but I guess that comes from within the vPilot software istself. What I have tried so far:

  • - Running vPilot as administrator
  • - Turning off firewall
  • - Restarted the computer
  • Configuring the PPT button

When I change COM1 frequency in my sim (MSFS, TBM 930), it changes in the COM1 frequency in the upper right corner of the vPilot software. I am running the vPilot.exe (not the "Host" or "Remote" mode as I have both vPilot and MSFS on the same computer.

When I study the vPilot help page, it kind of indicates that the COM1 frequency should be shown in cyan color (or is this only when using Host/Remote setup)? For me it the word "COM1" and the frequency itself is only shown in white all the time.

Any help would be very much appreciated!

 

Link to comment
Share on other sites

OK, thank you for the reply. I used the ATIS just to test if I hear something. But even if I tune to a ATC channel that should be quite busy, I do not hear anything. I have placed my aircraft at several airports where a lot is going on but never heard anything. So something must be wrong.

A question: Should the COM frequency be shown in blue for the audio to work? It kind of says here:

https://vpilot.rosscarlson.dev/Documentation#configuration

If you are connected to the voice server, the frequencies shown will be colored blue as shown in the image at right.

Is it possible to be connected to the VATSIM server and receive text messages, but not be connected to the "voice server" ? (I do not receive any errors when I start vPilot, or when I press Connect)

 

Edited by Tommy Rosengren
Link to comment
Share on other sites

14 minutes ago, Tommy Rosengren said:

Is it possible to be connected to the VATSIM server and receive text messages, but not be connected to the "voice server"

Yes, it is possible, they are two different servers. Perhaps something is blocking the voice server connection, like firewall or antivirus software.

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

2 minutes ago, Ross Carlson said:

Yes, it is possible, they are two different servers. Perhaps something is blocking the voice server connection, like firewall or antivirus software.

Thank you very much for the answer Ross. I guess the color of the COM frequency should be shown in blue is there is a connection to the Voice server, so as mine is in white I have to work on that connection.

Link to comment
Share on other sites

Spent another couple of hours to try to figure out what is wrong... but no success.

  • I can connect to the VATSIM server without any problem, no error messages shows up when I click Connect (I saw other posters indicating they got a specific error messages related to the Voice server connection, but I do not get any errors at all)
  • See the "Controllers in range" perfectly
  • Can see when someone uses text to communicate, and also hear the RadioMessage.wav sound when this takes place
  • When I tune my COM1 in my aircraft (MSFS, TBM 930) it changes in the upper right corner of vPilot

But the problem is: the COM1 frequency does not show in Blue, and I hear no real live talking on any of the channel that probably is quite busy....

Is there anyway to troubleshoot what is wrong? Does vPilot write any log file, or can I use some other method to find out what is blocking the voice communication. Its especially strange since no error message at all is shown during the connection.

What I have checked:

  • Starting vPilot at Administrator
  • Checked that there is full access to the vPilot folder
  • Double checked that correct CID and password is entered
  • Double checked that there are no mistakes with capital letters in the password
  • Disabled Firewall

Thankful for any help I can get, Best regards

Tommy

Link to comment
Share on other sites

Just found out the reason!

I had to select a microphone device (even if I just planned to listen). As soon as I selected a microphone device, it said "Connected to voice server" and everything was fine!

Hope this will help anyone else, and it could be clarified in the documentation perhaps. Thanks for all the help!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...