Jump to content

Another VAT-Spy not Opening on Multi-Monitor Setup Thread


Ike Callaway
 Share

Recommended Posts

The issue started about a week ago out of nowhere. First it was sporadic, now it won't open at all.

I have tried the following today:

Deleting the VATSpyConfig.xml will open VAT-Spy on Monitor 1. VatSpy will not open after closing it on Monitor 2. It works sporadically on Monitor 1.

I do not have Nahimic service running. This issue doesn't occur on my Surface.

Edited by Ike Callaway

logo2.png.90a40c2564324860397e893f65cf8c08.png

          Controller 1

Link to comment
Share on other sites

  • Ike Callaway changed the title to Another VAT-Spy not Opening on Multi-Monitor Setup Thread

The problem is the LastWindowLocation in VATSpyConfig.xml. If you close VATSpy on a monitor LEFT from your main monitor the position gets negative so VATSpy crashes on startup. I had the same issue with other programs, e.g. Prusa Slicer. Just change the value to a positive number and it restarts without issues.

  <LastWindowLocation>
    <X>-1235</X>
    <Y>341</Y>
  </LastWindowLocation>
Edited by Martin Ruskowski
Link to comment
Share on other sites

6 hours ago, Martin Ruskowski said:

The problem is the LastWindowLocation in VATSpyConfig.xml

Thanks for posting, Martin, but Ike already knows the issue is with VAT-Spy running on a secondary monitor. He's trying to fix it so that he doesn't have to always run it on the primary monitor.

For all other users that I've heard from, it was Nahimic Services that was causing the crash in VAT-Spy and other applications, but he says he's not running Nahimic Services, so I have no idea what would be causing it.

Ike, just to be sure, you ran the Windows Services control panel application and did not find Nahimic listed there?

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

On 11/28/2021 at 11:31 AM, Ross Carlson said:

Ike, just to be sure, you ran the Windows Services control panel application and did not find Nahimic listed there?

Correct. 

I also have an issue with vERAM not displaying anything I move over the second monitor. vSTARS and VRC are unaffected.

logo2.png.90a40c2564324860397e893f65cf8c08.png

          Controller 1

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...