Jump to content

Swift Model Set


Stefan Friedrich
 Share

Recommended Posts

Ok, now that we've got all the information, do the following:

  1. start swiftDATA app (Mapping Editor)
  2. on the bottom, select "Settings and login"
  3. in the Simulator section (top right part of the window) select FSX
  4. Simulator directory: check that you have set the correct FS2020-path for the category "FSX"
    fetch.php?media=configwizard_simulatorse
     
  5. Model directories: add the directories "Community" and "Official" and then SAVE these settings with the button on the right
    fetch.php?media=configwizard_simulatorse
     
  6. on the bottom of the app, select "Mapping editor" and then select the tab "Stored own models FSX" (on top of the program)
  7. click on the button "force reload FSX". This will make swift search the 2 directories that we just defined in step 5. At the end of the process it will show you ALL aircraft that were found in those folders. In other words: in this tab you only see what swift MAY be able to use in your model set.
  8. now change to the tab "Active model set FSX". swift will only be able to use and display models that are stored in this very tab! If it's empty, there will be nothing to display at all. To populate this tab, click on the button "new set", check all the settings and then confirm with "OK". After a few seconds, the tab should be filled with a lot of aircraft. If yes and if you are happy with the result, click on "save FSX" on the right side. Only now will the model set be saved.
  9. should you add new aircraft to your simulator, start over from step 1. until 8.

Note: at this time, swift 32bit has a problem/bug with permanently saving the settings for Simulator directory and Model directories. The next time that you will start swift, it will have forgotten those settings. The bug is known and the developers are working on it. Sorry for this!

As a result from what is mentioned in the note above, every time you start swiftGUI to fly online with FS2020, you MAY have select the "Settings" widget on swiftGUI and from the list choose "Simulator". In case that FS2020 is not set active, set the checkmark again and click on the button "Check again" to attempt to connect swift and FS2020.

Edited by Andreas Fuchs
Link to comment
Share on other sites

Hello Andreas,

once again thank you very much for your help! I did everything you said and…it works! 😀 Thank you!

But i have another question! I tried to connect myself. I was in Zurich at a B Gate and opened swiftGUI. After that i pressed the „connect“ button and it seemed that i was connected to the network. VatScope showed some traffic but i didn‘t saw nothing and i heard nothing on 122.800 (no ATC online).

I downloaded that XPlane Plugin but where i have to put when i fly with FS2020? Or this problem may be related with the bug you mentioned in your last post?

Once again thank you for your help!

Link to comment
Share on other sites

Good that you could create your model set.

Now, for your connection: when you have FS2020 and swiftGUI active at the same time and you select swiftGUI's "Connect" widget, is there a red, yellow or green frame around your own "Model"? https://docs.swift-project.org/doku.php?id=connect_online_flight_simulator_network_vatsim_fsd_login_page#own_aircraft

Make sure that FS2020 and swift are really connected to each other, check that you are connecting not just as "observer", but "normal".

Edited by Andreas Fuchs
Link to comment
Share on other sites

Did you check this, as in my first post: select the "Settings" widget on swiftGUI and from the list choose "Simulator". In case that FS2020 is not set active, set the checkmark again and click on the button "Check again" to attempt to connect swift and FS2020.

Link to comment
Share on other sites

Hello Andreas

So. i am a complicated case...sorry for that 🙄

Well i tried your suggestion but i think i need to install a Plugin to communicate between FS2020 and swiftGUI.

Here's what i see:

523474359_Screenshot2021-11-30130225.jpg.1a05e777e2c83d647f2255f2e975e118.jpg

As you can see i'm connected but there are no Planes around me. And EGLL was busy right now...

Then i clicked on "?" and this messages was shown:

IMG_1907.thumb.jpg.e0ff6f70a12d3242ea4b944a4699bd8c.jpg

So i think i have a missing Plugin! Can you give me some help? Where i have to put which Plugin?

Once again thank you for your patience and help!

Regards, 

Stefan

Link to comment
Share on other sites

Hey Andreas

It‘s working now 😀

What i did: I redownloaded swift again! My fault was that i unselectet some plugins when i was asked at the beginning of the installation 🥺

Now everything works pretty fine and i can start to learn more about swift and soon i will be back in the skies 😀

Thank you very much for all your help!

Greetings, Stefan

Link to comment
Share on other sites

Great! Then have fun with swift. In case that you are using Discord, you may want to join our swift support server. We got a few more helping hands on deck there.

https://docs.swift-project.org/doku.php?id=contact

Edited by Andreas Fuchs
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...