Jump to content

Issue with .ASDEX


Norman Maddox
 Share

Recommended Posts

Hello all,

I'm having another weird issue, and it's really frustrating. Seems no matter what ASDEX I try to load, my vstars crashes when doing ".asdex kphx or .asdex kdfw " I've already tried to remove vstars completely clear the config, remove every file associated with vstars start fresh basically like it's not even installed, but no luck... Any ideas? I've cleared vstars out my registry everything, wiped my computer clean of vstars.... It loads the first time, soon as I setup my F7 TC/TX/TN/TM/TV/ etc... commands and save my presets, I go to relog and my .asdex doesn't load... It's just a white screen and freezes my entire vstars program.. I've tried everything, and I'm really out of suggestions to try to trouble shoot... I've cleared configs, removed every file associated with vstars, installed it on different drives, installed as admin, ran it as admin tried different ARTCC sectors with asdex's and samething, so it's not the FE's fault, I'm not sure what's going on ūüė쬆Any suggestions very much appreciated, thanks again for your time.

Regards,


Norman Maddox Jr

Link to comment
Share on other sites

Yes, that's correct. vStars is on my primary monitor, and ASDEX is trying to open on a secondary monitor.

**Update** When I disconnect my secondary and launch the .asdex on the same screen (primary screen) there's no crash ūüė쬆Tell me you have a fix for this, Ross.. I don't want to have to keep disconnecting my secondary every time I want to control...

Edited by Norman Maddox
Link to comment
Share on other sites

I believe you're running into the same issue that users of VAT-Spy and vERAM have run into. There's a program that comes with some motherboards  (especially Asus) called Nahimic services. It's some kind of audio enhancement for games, I think. For some reason, it interferes with OpenGL applications (which VAT-Spy, vERAM, and vSTARS all are) and causes the lockup. Do some googling to learn how to see if you have the Nahimic Service running and how to disable it, and see if that fixes it.

Edited by Ross Carlson
  • Thanks 1

Developer: vPilot, VRC, vSTARS, vERAM, VAT-Spy

Senior Controller, Boston Virtual ARTCC

Link to comment
Share on other sites

Hi there. Found this thread and tried disabling the Nahimic Service and it for the most part worked. If I open the .ASDEX on my main monitor VSTARS is running on and I want to move it to the my secondary one and leave it there, it'll crash VSTARS and leave it hanging the next time I attempt to open the .ASDEX. This happens for both PDX and SEA airports where I control mostly. When I also try to open VSTARS on my secondary monitor it crashes instantly without warning instead the program hanging and not responding. As long as I open VSTARS on my main primary monitor everything seems to work fine, but when I try to use both is when I run into issues.

PC and monitor specs:

Processor    11th Gen Intel(R) Core(TM) i7-11700F @ 2.50GHz, 2501 Mhz, 8 Core(s), 16 Logical Processor(s)

NVIDIA GeForce RTX 3080

(Both monitors 2560x1440. Both G-SYNC enabled with max sync rate of 165 hz. Main monitor running on display port, second monitor running on HDMI port.) 

 

Thanks in advance for your assistance. Let me know if you need anymore information! 

 

Craig 

 

Edited by Craig Littleton
Link to comment
Share on other sites

12 minutes ago, Craig Littleton said:

Hi there. Found this thread and trying disabling the Nahimic Service and it for the most part. If I open the .ASDEX on my main monitor VSTARS is running on and I want to move it to the my secondary one and leave it there, it'll crash VSTARS and leave it hanging the next time I attempt to open the .ASDEX. This happens for both PDX and SEA airports where I control mostly. When I also try to open VSTARS on my secondary monitor it crashes instantly without warning instead the program hanging and not responding. As long as I open VSTARS on my main primary monitor everything seems to work fine, but when I try to use both is when I run into issues.

PC and monitor specs:

Processor    11th Gen Intel(R) Core(TM) i7-11700F @ 2.50GHz, 2501 Mhz, 8 Core(s), 16 Logical Processor(s)

NVIDIA GeForce RTX 3080

(Both monitors 2560x1440. Both G-SYNC enabled with max sync rate of 165 hz. Main monitor running on display port, second monitor running on HDMI port.) 

 

Thanks in advance for your assistance. Let me know if you need anymore information! 

 

Craig 

 

Follow this, best of luck. This should resolve your issue. I followed this, and now it's working fine with no issues.


e434369d246d634d0e4a2e60ff7c1b2a.png
https://gyazo.com/e434369d246d634d0e4a2e60ff7c1b2a

Link to comment
Share on other sites

1 minute ago, Norman Maddox said:

Follow this, best of luck. This should resolve your issue. I followed this, and now it's working fine with no issues.


e434369d246d634d0e4a2e60ff7c1b2a.png
https://gyazo.com/e434369d246d634d0e4a2e60ff7c1b2a

Hi Norman,

 

Thanks for the quick reply and assistance. I've already disabled that service on my PC and I still get the same results when attempting to utilize 2 monitors. Specifically opening .ASDEX where I left it on my second monitor last. It crashes if everything is not on my main display when it was closed last. 

Link to comment
Share on other sites

1 hour ago, Craig Littleton said:

Hi Norman,

 

Thanks for the quick reply and assistance. I've already disabled that service on my PC and I still get the same results when attempting to utilize 2 monitors. Specifically opening .ASDEX where I left it on my second monitor last. It crashes if everything is not on my main display when it was closed last. 

Did you make sure to close the service? It's probably still running, be sure to hit stop program as well after you follow those instructions then try it again. This should resolve your issue, if not, then I'm not sure. Maybe Ross can assist further, but this seems to be the likely of your cause since it was for mine too and after disabling and stopping the program from running on my system it resolved the .asdex issue.


Be sure in services.msc itlooks like this under the service 0e1cf23688c2bf8e82485f2ab8f70f02.png
https://gyazo.com/0e1cf23688c2bf8e82485f2ab8f70f02

Edited by Norman Maddox
Link to comment
Share on other sites

8 hours ago, Norman Maddox said:

Did you make sure to close the service? It's probably still running, be sure to hit stop program as well after you follow those instructions then try it again. This should resolve your issue, if not, then I'm not sure. Maybe Ross can assist further, but this seems to be the likely of your cause since it was for mine too and after disabling and stopping the program from running on my system it resolved the .asdex issue.


Be sure in services.msc itlooks like this under the service 0e1cf23688c2bf8e82485f2ab8f70f02.png
https://gyazo.com/0e1cf23688c2bf8e82485f2ab8f70f02

 

Yes, it is stopped and disabled on startup as well.

 

image.png.b32ad5d68263bc743ee75fcacb8f3a62.png

Link to comment
Share on other sites

Try doing a fresh install of vStars like remove everything the files that are left behind when you uninstall. Everything. What I did was went to " This PC " searched vStars and got rid of every file, I even went as far as removing everything out of my registry not sure if you need to go to that extend, but that is what I did. After removing the NahmimicService I no longer have any issues with .asdex opening on my secondary screen. I would try at least removing all vstars files from your PC, and then doing a fresh install or maybe running vStars on another drive and see if that fixes it. 

1 hour ago, Craig Littleton said:

 

Yes, it is stopped and disabled on startup as well.

 

image.png.b32ad5d68263bc743ee75fcacb8f3a62.png

 

Link to comment
Share on other sites

37 minutes ago, Norman Maddox said:

Try doing a fresh install of vStars like remove everything the files that are left behind when you uninstall. Everything. What I did was went to " This PC " searched vStars and got rid of every file, I even went as far as removing everything out of my registry not sure if you need to go to that extend, but that is what I did. After removing the NahmimicService I no longer have any issues with .asdex opening on my secondary screen. I would try at least removing all vstars files from your PC, and then doing a fresh install or maybe running vStars on another drive and see if that fixes it. 

 

I did reinstall VSTARS 3 times prior to finding out about the Nahimic Service. So maybe another fresh install will help the cause here. I will do that and update further if the problem persists thank you! 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...